2

Linux newbie here. I've tried looking at other threads, but haven't been able to figure this out.

I just installed Ubuntu 14.04 LTS (32 Bit) on an Asus 1015PEM netbook with a Ralink RT3090 wifi card. I did a complete install and wiped Windows 7 off the system.

Wifi worked great with 7, I had a 65 Mbps connection. Now it drops to 6 or 1 Mbps and I cannot connect Wirelessly.

Here is part of what I got with lshw:

*-network
description: Wireless interface product: RT3090 Wireless 802.11n 1T/1R PCIe vendor: Ralink corp. physical id: 0 bus info: pci@0000:02:00.0 logical name: wlan0 version: 00 serial: 48:5d:60:6a:80:9e width: 32 bits clock: 33MHz capabilities: bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=rt2800pci driverversion=4.2.0-30-generic firmware=0.34 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn resources: irq:17 memory:fbff0000-fbffffff

Help!

  • Also is your network/router set to Wireless N? – hazrpg Mar 2 '16 at 0:18
  • Yes, it is. I have also tried b/g/n. – Rick R Mar 3 '16 at 19:13
  • Do you mean you tried setting your router to only broadcast b only, then g only and then n only? With my laptop I had to disable wireless n either at the router or on the laptop to prevent the issues you're also having. However my card is different, I have the Intel Centrino Wiressless N. – hazrpg Mar 3 '16 at 19:51
  • No. I used the performance mode n setting only, and then tried the compatibility mode b/g/n. I really don't want to disable n and slow down my other connections. – Rick R Mar 4 '16 at 17:04
0

What is your current kernel?

You can find that thru a uname - r https://www.kernel.org Check if your version is the latest if not http://www.yourownlinux.com/2016/02/how-to-install-linux-kernel-4-4-3-in-linux.html?m=1

Follow the instructions on the link below and select 32 or 64 according to your distro type.

This happened on a laptop of mine and updating kernel sorted the problem maybe this can fix your problem as well

  • I had an older one and updated to 4.4.3. Still no good. I have been using a T Link micro usb adapter, which uses a Realtek driver and works fine. Still, I'd rather have the internal one working. – Rick R Mar 3 '16 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.