11

After upgrading to Ubuntu 11.10, I once right-clicked on a folder and told it to open the folder with Movie Player ("Open with other application...").

No harm done there, right? Nope, now Ubuntu opens folders with Movie Player instead of Nautilus. If I plug in a thumb drive, Movie Player opens.

If I click on the trash icon... Movie Player! The default action for opening a folder has somehow become Movie Player. Clicking on the "Home Folder" icon still opens Nautilus and opening a folder in Nautilus stays in Nautilus, but other links to folders automatically open Movie Player. How can I change this back?

13

Answer edited out from the question

Solution was obvious, in Nautilus I select a folder, right click, Open with other application, and pick "Files" which is apparently the name for Nautilus. Now that set the default back... until next time! I guess this is a cautionary tale.

  • 1
    As indicated under first comment here and also here, most probably this will be lost after update. – user47206 Jan 13 '17 at 11:58
  • It does not work for the latest version anymore. – takeshin Apr 30 '19 at 9:04
2

In your home folder go to .local/share/applications/mimeapps.list It is a hidden file. You can unhide it with the following keyboard shortcut: Ctrl + H .

You then need to modify the line inode/directory=movie-player.desktop; or something like that, to inode/directory=nautilus-folder-handler.desktop; and save the file.

2

On Ubuntu 14.04, this one works for me:

xdg-mime default nautilus.desktop inode/directory

Original answer comes from here and here

The command above adds a line inode/directory=nautilus.desktop to your .local/share/applications/mimeapps.list

Works instantly without logging out/restart.

  • nautilus.desktop has been renamed to org.gnome.Nautilus.desktop – theferrit32 Aug 1 '19 at 20:34
1

My original problem was that right-click "Open Containing Folder" didn't work for me in Banshee or File Roller on Ubuntu 13.10 64-bit. The dialog was a Shotwell dialog saying "unable to open folder". I tried deleting ~/.local/share/applications/mimeapps.list but that just forgot all my default application settings and had no effect on my original problem.

Here's what worked (I marked some things as "No Effect" meaning that I think these steps are unnecessary, but I can't be sure):

  • I uninstalled shotwell sudo apt-get remove shotwell then reinstalled it again sudo apt-get install shotwell. Now "Open Containing Folder" opened wrongly in Disk Usage Analyzer (baobab)

  • No Effect: I added nautilus.desktop to this line in mimeapps.list: inode/directory=nautilus-folder-handler.desktop;nautilus.desktop;

  • No Effect: I tried uninstalling and re-installing nautalis sudo apt-get remove nautilus nautilus-folder-handler sudo apt-get install nautilus nautilus-sendto nautilus-share I suspect this was a waste of time.

  • I uninstalled Disk Usage Analyzer sudo apt-get remove baobab and reinstalled it apt-get install baobab and that fixed it!

0

As indicated here.

You can define the default file browser by editing the file ~/.local/share/applications/mimeapps.list. It should look like:

[Default Applications]
inode/directory=nautilus-folder-handler.desktop;

In other systems, the file to be edited is ~/.local/share/applications/mimeinfo.cache

[MIME Cache]

inode/directory=nautilus-folder-handler.desktop;

To avoid the problem entirely: https://unix.stackexchange.com/q/336982/32012

0

Ubuntu Mate: System->Preferences->Personal->Preferred Applications Open "System" tab; change "File Manager" to "Caja" to restore default behavior.

  • This is not an answer for this question. – pim May 8 '18 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.