I'm running a dual boot of both Ubuntu 11.10 and Windows 7. I have two hard drives, and three partitions: Windows 7 on a dedicated SSD, Ubuntu on the second hard drive, first partition, and then a "Data" partition on that same drive. I have already moved all my linked "libraries" from Windows to the "Data" partition.

Note: The Data partition is a ntfs partition. I really don't want to change it, but can if necessary

What I'm wanting is to have access to my common files under the same folder. For example, I want my "My Documents" (Windows 7) folder to correspond to my "Documents" (Ubuntu) folder; my "My Music" (Windows 7) folder to correspond to "Music" (Ubuntu) folder; etc,.

Is there any way to easily do this?


1 Answer 1


Step 1: I'm not sure if an NTFS drive is mounted by Ubuntu automatically or if you need to click on it in Nautilus in order to mount it - and I have no NTFS partition to test this. In the case it's not auto-mounted, you could add a line to /etc/fstab to mount it on boot.

There's some info in Ubuntu wiki on the subject

Step 2: Suppose your NTFS partition is mounted in /media/disk_c. Then you can just create symlinks in your home directory to the folders on the NTFS partition.

If you want to replace the "built-in" Documents, Pictures directories, I would advice to remove them in terminal because Nautilus tracks any changes to those "special" folders when you change them via Nautilus and adjusts its settings, so renaming Documents to Documents.old and creating a new Documents symlink via Nautilus would not behave as you expect

rm -rf /home/myusername/Documents
ln -s "/media/disk_c/whereever/the/target/folder/lives/in/windows/My Documents" /home/myusername/Documents
  • I keep getting the error of "Could not display "/home/kronos/Music" (or any other changed link) "The location is not a folder" Commented Nov 1, 2011 at 0:14
  • Ah... nvm... I forgot that the folder I was linking to was /media/files/KronoS and not media/files/Kronos. Morale of the story.. make sure that you enter your directory correctly. Commented Nov 1, 2011 at 0:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .