0

After installing a software, Ubuntu boots correctly but Unity does not show up (only desktop icons appear).

I tried: sudo apt-get -f install

user@pc:~$ sudo apt-get -f install
[sudo] password for user: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... non riuscita.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libc-dev-bin : Dipende: libc6 (< 2.16)
 libc6 : Rompe: libc6:i386 (!= 2.18-0ubuntu4) ma la versione 2.15-0ubuntu10.13 è installata
 libc6:i386 : Rompe: libc6 (!= 2.15-0ubuntu10.13)
 libc6-dev : Dipende: libc6 (= 2.15-0ubuntu10.13)
 libc6-i386 : Dipende: libc6 (= 2.15-0ubuntu10.13)
 libnih1 : Pre-dipende: libc6 (< 2.16)
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.
E: Impossibile correggere le dipendenze

It's an Italian installation: "Rompe" = "Breaks", "Dipende" = "Depends"

How can I solve this?

EDIT translation

user@pc:~$ sudo apt-get -f install
[sudo] password for user: 
Reading package lists ... Done
dependency tree generation
Reading state information ... Done
Correcting dependencies ... failed.
The following packages have unmet dependencies :
 libc - dev - bin : Depends: libc6 ( < 2.16)
 libc6 : Breaks : libc6 : i386 ( ! = 2.18-0ubuntu4 ) but 2.15-0ubuntu10.13 version is installed
 libc6 : i386 : Breaks : libc6 ( ! = 2.15-0ubuntu10.13 )
 libc6 - dev : Depends: libc6 ( = 2.15-0ubuntu10.13 )
 libc6 - i386 : Depends: libc6 ( = 2.15-0ubuntu10.13 )
 libnih1 : Pre -Depends : libc6 ( < 2.16)
E: Error , pkgProblemResolver :: Resolve generated breaks. This could be caused by held packages .
E: Unable to correct dependencies
0

Edit /etc/apt/sources.list

add the following line:

deb http://security.ubuntu.com/ubuntu precise-security main 

update and type:

sudo apt-get -f install

sudo apt-get build-dep your_package_name

Edit

Type:

sudo apt-get remove libc6:i386=2.18-0ubuntu4

then:

sudo apt-get install libc6=2.15-0ubuntu10.13
sudo apt-get install libc6:i386=2.15-0ubuntu10.13
  • I followed all the steps, but unfortunately it did not solve the problem. – user59114 Feb 27 '16 at 13:53
  • I also tried this: user@pc:/$ sudo dpkg --configure -a dpkg: errore nell'elaborare libc6 (--configure): libc6:amd64 2.18-0ubuntu4 cannot be configured because libc6:i386 is in a different version (2.15-0ubuntu10.13) dpkg: errore nell'elaborare libc6:i386 (--configure): libc6:i386 2.15-0ubuntu10.13 cannot be configured because libc6:amd64 is in a different version (2.18-0ubuntu4) Si sono verificati degli errori nell'elaborazione: libc6 libc6:i386 – user59114 Feb 27 '16 at 14:08
  • You need to remove libc6:i386=2.18-0ubuntu4 – GAD3R Feb 27 '16 at 14:17
  • sudo apt-get remove libc6:i386=2.18-0ubuntu4</ br> Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze Lettura informazioni sullo stato... Fatto E: Version "2.18-0ubuntu4" per "libc6:i386" non trovato – user59114 Feb 27 '16 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.