3

I have an AMD E1 1200 dual core processor. I'm trying to start a virtual machine with Oracle VirtualBox but am having errors.

Is there a way to check that my CPU supports virtualization and is enabled? If so, how do I turn it on? Below is all the steps I've taken thus far including the error message pasted at the bottom of this message

I opened up the system settings in BIOS and under system configurations looked for an option to enable virtualization but could not find one in any of the BIOS menus.

I downloaded "Speccy" by piriform to see what it could ascertain. It is saying my system both supports virtualization and that it is currently enabled.

I then tried to confirm that the CPU was virtualization enabled with AMD virtualization technology and Microsoft Hyper-V Compatibility check Utility available from AMD support. This software is telling me that my system is not virtualization enabled contradicting the message from Speccy.

I also tried loading the virtual machine with only 1 processor because some individuals on Super User stackexchange forums said that solved their problem but no such luck for me.

ERROR MESSAGE

Failed to open a session for the virtual machine XXX.

AMD-V is disabled in the BIOS (or by the host OS). (VERR_SVM_DISABLED).

Result Code: E_FAIL (0x80004005)Component: ConsoleInterface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}
  • 1
    Look in /proc/cpuinfo for the svm flag. If that is not in there, then it is disabled in the BIOS. You also might need a BIOS update to enable it. In doubt contact the mainboard vendor. – Thomas Feb 26 '16 at 17:57
  • If there is no option in bios to turn it on, then you are unlucky. – Pilot6 Feb 26 '16 at 18:21
  • Does your processor really supports virtualization? Please google for that? – Ashu Feb 26 '16 at 18:25
  • @Ashu Thanks for the suggestion. I wondered the same thing. Couldn't find my processor on the AMD website. [link](products.amd.com/en-us/… – Nirvan Sengupta Feb 26 '16 at 18:33
  • Please edit your question and add output of LANG=C lscpu | grep Virt terminal command. – Pilot6 Feb 26 '16 at 18:49
3

Step 1

Reboot the computer and open the system's BIOS menu. This can usually be done by pressing the delete key, the F1 key or Alt and F4 keys depending on the system.

Select Restore Defaults or Restore Optimized Defaults, and then select Save & Exit.

Power off the machine and disconnect the power supply.

Step 2

Enabling the virtualization extensions in BIOS

Power on the machine and open the BIOS (as per Step 1).

Open the Processor submenu The processor settings menu may be hidden in the Chipset, Advanced CPU Configuration or Northbridge.

Enable Intel Virtualization Technology (also known as Intel VT) or AMD-V depending on the brand of the processor. The virtualization extensions may be labeled Virtualization Extensions, Vanderpool or various other names depending on the OEM and system BIOS.

Enable Intel VTd or AMD IOMMU, if the options are available.

Save & Exit.

Run

cat /proc/cpuinfo | grep --color 'vmx\|svm'

If you see vmx or svm in red, the virtualization extensions are now enabled. If there is no output your system may not have the virtualization extensions or the correct BIOS setting enabled.

| improve this answer | |
  • In my case, /proc/cpuinfo shows svm is enabled, and $ LANG=C lscpu | grep Virt shows Virtualisation: AMD-V, but I still get the error – Auspex Jan 1 '19 at 15:36
  • 1
    Note that in some Mainboards the AMD-V/Virtualization Setting is called "SVM", which stands for "secure virtual machine mode". AMD-V is just a branding on top of it. – rwenz3l Jan 30 '19 at 8:54
1

On my setup (AMD Ryzen / MSI B450M-A PRO MAX), /proc/cpuinfo listed the svm feature, and lscpu listed AMD-V, even though it was disabled in the BIOS.

The BIOS setting to enable AMD-V was hard to find, as it was located in Overclocking > CPU Features > SVM mode.

Hope this helps people finding this thread.

| improve this answer | |
-1

As clearly mentioned in the error message you need to enable the virtualization in the BIOS. Please refer to your system manual for enabling it. VMWare or Virtual box needs that to be enabled in BIOS so that they can work.

| improve this answer | |
  • As I mentioned in my post, there is no option to enable virtualization in the BIOS. Thanks for the message. – Nirvan Sengupta Feb 26 '16 at 18:14
  • As Thomas also stated in the comment...options 1) BIOS update 2) Talk to Tech Support of the system to get more details in terms of how to do that. – Ashu Feb 26 '16 at 18:19
  • What a terrible answer! When was the last time you got a "system manual" with a computer that told you anything more than how to get started with Windows? If you do call Tech Support, they invariably tell you they don't support Linux. In any case, I get this message even though AMD-V virtualization is shown as enabled. – Auspex Jan 1 '19 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.