0

I'm using an Ubuntu 14.04 system and I'm trying to install skype on my system. I followed the steps given in the following link to install here. I first tried installing the .deb package from their site and Software Center says it needs libqt4-dev:i386 and stops download. I tried to install directly from the software center and it gives an unmet dependencies error with skype-bin package. I tried to install the missing packages using apt-get but that didn't work either.

How do I fix this so I can get Skype to work properly?

Edit#1: I tried the following code:

sudo apt-get install -f sudo dpkg --add-architecture i386 sudo apt-get update wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb sudo dpkg -i skype-install.deb

Skpe gets installed but it shows there were some during installation.(Deosn't list the errors though). I get this message:

Errors were encountered while processing: skype The skype logo shows up in the launcher but it doesn't run. I tried running it from terminal and got this error:

skype: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory

  • I've tried apt-get -f install and fixing broken packages using synaptic. Didn't work. – SY_13 Feb 26 '16 at 17:28
  • Run sudo apt-get install libxv-dev:i386 and then check.. – heemayl Feb 26 '16 at 17:45
  • I get an error saying I have some unmet dependencies. I try apt-get -f install but it shows E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. unable to correct dependcies – SY_13 Feb 26 '16 at 18:45
  • Okay, I removed the broken packages using aptitude. I used this code - sudo aptitude -fy remove mono-runtime. But I still get the same error when I try to install skype. – SY_13 Feb 27 '16 at 7:17
  • It looks like you are trying to install the wrong .deb file. The link above is for Debian, while you should have picked Ubuntu. I'd suggest that you purge skype, and install it from Canonical Partners instead (sudo apt-get install skype skype-bin). – Gunnar Hjalmarsson Feb 27 '16 at 10:40
1

Prior to version Skype 4.3, it was available as binary file, so that users can only download the binary file from it’s official and install it manually. But, as of version 4.3, Skype is available in the Canonical Partners repository.

To enable the Canonical Partners repository, go to Software & Updates from Unity dash. Navigate to Other Software tab, and enable Canonical Partners repository.

Click Close, and Reload buttons to update the cache. Then, type the following command to install Skype.

sudo apt-get install skype

Edit

According to http://packages.ubuntu.com/ Edit /etc/apt/sources.list

Add the following line

deb http://security.ubuntu.com/ubuntu trusty-security main 

Save and update Then run

sudo apt-get install libxss1:i386 libqtcore4:i386 libqt4-dbus:i386 libqtgui4:i386

Finally run

sudo apt-get install skype
  • Canonical Partners is selected already. – SY_13 Feb 26 '16 at 18:47
0

Try to start skype from terminal like this:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libXv.so.1 skype
  • Okay I tried the code above and got this error : ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libXv.so.1' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored. skype: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory – SY_13 Feb 27 '16 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.