0

It goes like this:

Ubutu 14.04 LTS

I keep it fairly up to date. Usually allow updates when nagged. Was nagged this morning and allowed update. Rebooted. Got a message that something failed. Assumed it was because my /boot was full (again!). Used a procedure that I have used many times to purge old kernel and related files to reclaim space. Assume I over-reclaimed". Ran updater again. It then said I had to reboot. Allowed reboot. Nothing there but air.

I am now running from the original install CD (try ubuntu option). Installed boot-repair but it is stuck on "Purge kernels then reinstall last kernel sda6 (ins). This may require severlal minutes"

Then I installed boot-info and created a report here:

http://paste.ubuntu.com/15206613/

Any advice?

Thanks, Dan

  • Same here. Fresh install from ISO, made a clone, updated the clone. Update hangs "configuring grub-pc". – phunctor Feb 26 '16 at 18:15
0

OK. Its fixed now by boot-repair. Not sure what I did to fix it but I killed the one that was hung and tried this:

How to restore a system after accidentally removing all kernels?

Rebooted. No help.

Then I tried reinstalling grub (sorry, lost the link but it was a vanilla sudo apt-get ... command).

Rebooted. No help.

After those two attempts, I rebooted from the 14.04 install CD (try ubuntu option), then ran boot-repair again and it completed with a happy message saying that it was fixed and I could reboot. Maybe it would have just worked the second time through without my other gyrations.

Rebooted. Profit!

Good luck to those who come along later on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.