1

I installed Ubuntu 15.10 in VirtualBox 5.0 on Windows 10. I installed guest-additions (virtualbox-guest-additions and virtualbox-guest-addition). When i try to mount a shared folder, it fails with the message : "vboxsf failed with the error : no such device". I used the fixs listed on this topic : including the relinking of mount.vboxsf, but it didn't fix the error, and other people are encountering the same problem.

I don't want to download kernel headers and compiler and compile the modules, packages provided by Ubuntu should work, shouldn't they ?

1

I had this exact same problem. Which version of VirtualBox, specifically? I had 5.0.14 along with Ubuntu 15.10. Whenever I tried to install the guest additions things, there was a cryptic message saying,

The headers for the current running kernel were not found. If the following module compilation fails then this could be the reason.

However, nothing failed to build, at least, no error messages appeared on screen to that effect. Additionally, the display driver did seem to work, and I was able to set higher resolution for the display, although it did not have the resolution of my native monitor.

Looking at the changelogs for VirtualBox, there was a mention in v.16 or .18 about fixing something related to SharedFolders or something not building correctly from the additions.

The "simple" solution I tried (note this 3 months later), was to upgrade both VirtualBox (5.0.20) and Ubuntu (16.10).

Then deleted all the virtual machines, recreated, reinstalled Ubuntu.

Then installed the guest additions stuff, either from ISO in the C:\Program Files\VirtualBox folder (or wherever) or the .extpack.

Then all I did then was to define a shared folder in VirtualBox, and choose to mount it automatically. And it was mounted under /media/sf_* where * is whatever name you gave the share in VirtualBox.

The final task was to add my user to the vboxsf group, and logout and/or restart.

sudo usermod -a -G vboxsf <username>

A reboot and I was able to change display dimensions and read/write access to shared folder.

  • Not sure why the editor changed from a quotation to a code block. I was quoting (paraphrasing) some natural language text output from a script. It was not code. The resultant visual format is nearly identical. Just confused about the nature of the nit. If anything, a more substantial edit correcting the actual text output, and removing the "paraphrased" wording, would have been a more effective use of time and energy. – user314159 Jun 2 '16 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.