I am brand new to the Linux community, and I have installed Ubuntu 14.04. However, I am having some issues with Wifi. Ubuntu does not recognize Wifi at all, and I think it might be a communication problem between the hardware and Ubuntu. I am using a brand new Lenovo Y700 with an intel Core i7 processor.

When I search in terminal for network hardware it recognizes the Intel Wireless 8260 wireless card, but says that it is unclaimed.

lshw -class network

  *-network UNCLAIMED     
   description: Network controller
   product: Wireless 8260
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   version: 3a
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list
   configuration: latency=0
   resources: memory:94100000-94101fff
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:09:00.0
   logical name: eth0
   version: 15
   serial: 50:7b:9d:5f:1e:82
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:24 ioport:3000(size=256) memory:94004000-94004fff memory:94000000-94003fff

and searching the network interface configuration does not show a WLAN device.

sudo ifconfig -a

eth0      Link encap:Ethernet  HWaddr 50:7b:9d:5f:1e:82  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:16 errors:0 dropped:0 overruns:0 frame:0
      TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1184 (1.1 KB)  TX bytes:1184 (1.1 KB)

also, there is no information listed for a wireless card in rfkill

rfkill list all

0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no

Here is the result of uname -r


I have also attempted to add the proprietary internet drivers by going to System Settings -> Software and Updates -> Additional Drivers, and no proprietary drivers appear. I have searched in a number of places, but cannot find a solution that works.

How can I get Ubuntu to recognize that there is a wireless card in my computer? A hitch in my giddyup is that I do not have access to ethernet so am unable to just try adding different packages and installations easily.

Any help would be greatly appreciated. Could it be that I am having issues because this is a newer computer? or because it is designed for gaming? or just because I am new to Linux?

Thanks for any information, and please let me know any other information you'd like posted.


  • Please ask one question at a time. So what do you want to fix first, wireless or wired connection? Choose one and edit your question respectively.
    – Pilot6
    Feb 25, 2016 at 12:19
  • Thanks, Pilot. I've edited to just focus on Wifi for now. However, I don't have ethernet, so can't use many of the suggestions that are on other forums.
    – PaulFrater
    Feb 25, 2016 at 12:52
  • OK. We can fix the ethernet later. Please edit your question and add output of uname -r terminal command.
    – Pilot6
    Feb 25, 2016 at 13:15
  • Hold on, I will check what exactly this kernel does support.
    – Pilot6
    Feb 25, 2016 at 13:25

1 Answer 1


It looks like you installed Ubuntu 14.04.3 with kernel 3.19.

The problem is that the kernel 3.19 does support Intel 8260, but it needs firmware that is not in the original linux-firmware file.

It is even worse. This kernel supports firmware version 9-12 for this adapter, but the trusty-updates package has version 13.

Since you just did a fresh install, I suggest to download and install Ubuntu 14.04.4, that does support the wireless adapter.

Ubuntu 14.04.4 will install kernel 4.2 that supports firmware version 10-15 and you will get firmware v. 13 out-of-the-box.

That will be much easier than to upgrade the kernel without any internet access.

Hopefully your Ethernet adapter will work too. If this is not the case, you can ask another question regarding the Ethernet.

For Lenovo Yoga 700 the wireles adapter is blocked by ideapad_laptop kernel module. You can temporarily fix it by running

sudo modprobe -r ideapad_laptop

This issue has been fixed in the last kernel update since 4.2.0-28. After you install the system and update the kernel, your wireless adapter should work.

Do not forget to install updates for your system and you will not need to stop ideapad_laptop any more.

  • Thanks, Pilot. I believe it was 14.04.3, and the uname -r result is now shown in the question: 3.19.0-25-generic. I have a live USB of 14.04.4 at home, so I will try reinstalling that tonight. Do I have to wipe out the partition before reinstalling? I tried installing 15.10 last night, but it kept booting into the grub2 screen when I selected 'Install Ubuntu' while booting from the USB.
    – PaulFrater
    Feb 25, 2016 at 13:27
  • I will expand the question.
    – Pilot6
    Feb 25, 2016 at 13:29
  • Thanks for your help, Pilot. I will try this tonight and let you know the result.
    – PaulFrater
    Feb 25, 2016 at 13:39
  • It might be worth trying to rename the firmware file to make the module think it is a -12.ucode
    – Jeremy31
    Feb 25, 2016 at 15:46
  • That may be a good idea, but I am not sure there is one.
    – Pilot6
    Feb 25, 2016 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.