0

I am trying to update Ubuntu 14.04. But sudo apt-get update is returning the following errors.

0% [Connecting to in.archive.ubuntu.com] [Connecting to archive
0% [Connecting to in.archive.ubuntu.com] [Connecting to archive
Err http://in.archive.ubuntu.com trusty InRelease
Err http://archive.canonical.com trusty InRelease
Err http://extras.ubuntu.com trusty InRelease
Err http://in.archive.ubuntu.com trusty Release.gpg

Could not resolve 'in.archive.ubuntu.com'
Err http://archive.canonical.com trusty Release.gpg

Could not resolve 'archive.canonical.com'
Err http://extras.ubuntu.com trusty Release.gpg
Could not resolve 'extras.ubuntu.com'
Reading package lists...Done
W:Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/trusty/InRelease
W:Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/InRelease
W:Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg
Could not resolve 'in.archive.ubuntu.com'
W:Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg
Could not resolve 'archive.canonical.com'
W:Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg
Could not resolve 'extras.ubuntu.com'
W:Some index files failed to download.They have been ignored or old ones used instead.
2

3 Answers 3

0

I am facing with same problem. From the errors you can see that you are using the Ubuntu Server in India. Change the update server to something other than India. Go to Setting > Software & update --- under Ubuntu Software tab, find the drop-down list to choose the server for downloading updates from. Choose main server.

See this:

enter image description here

1
  • Thanks for the quick reply. But this solution did not work for me. I had configured internal network earlier and now I have changed it to NAT. Does this create a problem?
    – Rainbow
    Feb 25, 2016 at 6:45
-2

Repository[prbm]

        There is a spelling mistake on your link on sources.list it will be present on a directory (/etc/apt/). There you will be able to see the file called sources.list and sources.list.save. Manually copy the contents of file sources.list.save to sources.list. Else use following commands on terminal.(Make sure that you logged on root permission / You need to know the administrator password).

sudo rm /etc/apt/sources.list
sudo cp /etc/apt/sources.list.save /etc/apt/sources.list
sudo apt-get update
sudo apt-get update --fix-missing

I hope it will works fine..

2
  • Thanks for replying. The same problem still persists though.
    – Rainbow
    Feb 25, 2016 at 6:53
  • 1
    On what basis you said 'There is a spelling mistake on your link on sources.list'? Just a guess or some clue from the errors? Feb 25, 2016 at 7:27
-2

I am in Kashmir. I just updated my Ubuntu (15.10) from main server in last few min. Please give a try to updating from the main server and do update using apt command instead of apt-get:

sudo apt update

and share the error result


I don't know why you removed the screenshot of the errors in your question. it was useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.