I've set up my user account so that no password is required to login and I need to install some updates. However when prompted for the password, it says authentication failed if I leave the box blank. I don't have a password, how am I supposed to authenticate?


I tried the method in Reset lost administrative(root) password but it came out with an error: Authentication token manipulation error password unchanged. What does this mean?


Auto login is not password less, it just bypasses the password and logs you in automatic. you still have a password, its the same one you used for the installation and the installation wont run if the password box is empty. You must have used something to install, that is the same password you need atm.

| improve this answer | |
  • I tried that password but it failed :/ – Greg Treleaven Oct 30 '11 at 20:19
  • 1
    then you miss typed it now or during the installation, look in askubuntu on how to reset you password, there are many questions that will help you. – Bruno Pereira Oct 30 '11 at 20:21
  • here, check this if you need to reset your password. – Bruno Pereira Oct 30 '11 at 20:23

All you have to do is go to Users and Groups, then set a password. I didn't have a password originally but after trying for ages, I just set a password on the default administrator account and entered that same password when it was asking for authentication and it worked.

| improve this answer | |

When at grub (hold shift while loading) press 'e'. You'll enter a boot parameters edit mode.

Find a section with your kernel, actually you'll need line like:

linux /boot/vmlinuz-3.0.0-17-generic root=...

Append the line with "init=/bin/bash" and press Ctrl+x

You'll boot to a shell with root privileges. Use 'passwd' to change root password.

| improve this answer | |

You may try this... It worked for me...

sudo passwd root

It first asks for your password. Then changes root password

If you forgot your password you may be able to do this by creating new user a/c and then entering that new password

Hope that helps...

| improve this answer | |

Drop to root shell as in the link you mentioned and before resetting the password, remount the file system using the command:

mount -rw -o remount /

After that you may update your password by the command:

passwd <user_name>

eg. passwd sam

After that enter a valid password ( meeting the minimum requirements for strength) and confirm it when prompted. This should work out.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.