1

Android (4.2.2) phone (HTC Desire 310) is detected by Ubuntu 14.04.4 LTS successfully. Nautilus starts automatically.

But only a few folders are shown. And there are missing much more folders and files. For example in the music folder only 6 directories are shown, but I know that there are more than 10 on the device.

The device is connected via USB over MTP. There is no choice for Mass Storage Device any more in Android (since 4.1 I think).

Does anyone have an idea?

1

I guess it's this known issue. The problem is basically that the MediaStorage cache is not updated and thus files and directories created since the last update don't show up.
You could try one of the steps provided in this answer:

  • reboot the phone
  • Clear the "Media Storage" app's data
  • use an app like SDrescan to force an update of the MediaStorage


Alternatively you could transfer the files via wifi. There may be other ways to do this but my favourite method is running an ftp server on the phone and accessing that through nautilus:

  • First of all, you should only do this in a trusted local network (e.g. at your home)

  • make sure your smartphone and your PC are connected to the same local network

Smartphone

  • install an app like Ftp Server on your android phone and freely choose user name and password (and disable "Anonymous user").
  • start the server (by tapping the red on/off icon if you use Ftp Server)

Computer

  • open Nautilus on your PC and click on "Connect to Server" at the bottom of the list on the left
  • in the dialogue, enter the url that is displayed in the Ftp Server app (something like "ftp://192.168.178.13:2221")
  • when prompted, enter the user name and password you configured in the app

You're done! You can even bookmark that location in Nautilus. Whenever you want to transfer files, just connect smartphone and PC to your local network, start Ftp Server on the phone and click on the bookmark in Nautilus.

  • Thank you for the quick answer. But I don't think it's the same issue. Perhaps it's some kind of the known issue. I tried the steps (reboot phone, clear MediaStorage app's data, use SD Scanner to force an update of MediaStorage). But in the last step SD Scanner always stops scanning at different files. And the result after connecting to Ubuntu is the same as described in the question above. – sjuk Feb 24 '16 at 23:09
  • Thank you for the workaround. I tried it with SSH Server app. It's not that comfortable like using FileZilla with ftp. But I would love to use storage of the phone over nautilus or another favourite file manager. – sjuk Feb 24 '16 at 23:13
  • If SD Scanner stops at different files you might want to try a different app, or give some custom ROM a try which supports USB mass storage. Anyways, if you want to use the storage by means of the file system, MTP (media transfer protocol) is not the right choice since it is designed to NOT resemble the whole file system structure. What is wrong with the FTP approach? FTP (file transfer protocol) does expose the directory structure and Nautilus has an integrated ftp client. If you set it up like I described, it will look exactly the same in Nautilus as when connecting the USB mass storage. – danzel Feb 25 '16 at 8:54
  • I want to transfer media from one device to another, for example music and pictures. And someone calls the interface Media Transfer Protocol. So why should it be not designed to show me which media I can choose to transfer? – sjuk Feb 25 '16 at 18:37
  • Only guessing, do I perhaps need a special client software on Ubuntu? Or should I try another file manager who can handle the MTP better than nautilus? Don't get me wrong. I am very glad to get those quick answers from you. Really, I mean it: Thank you. And there is nothing wrong with the ftp-workaround. I only wanted to give you the chance to get the information that there are other workarounds like ssh. And I'm sure there are many other workarounds. But my question was about mtp, and not a workaround. Please be so kind to let me come back to the roots of the question. – sjuk Feb 25 '16 at 18:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.