11

I just downloaded openmpi 1.10.2 from https://www.open-mpi.org/software/ompi/v1.10/ and installed it on my ubuntu 14.04LTS(./configure then make all install). But when I try to use mpiCC to compile a .cpp file, I get the error:

mpiCC: error while loading shared libraries: libopen-pal.so.13: cannot open shared object file: No such file or directory

Some people on the internet say that putting the path of the lib directory under the openmpi directory into the LD_LIBRARY_PATH environmental variable should solve the problem, but it didn't!

Also, it seems that there is no file by the name "libopen-pal.so.13" on my computer. The closest ones I could find under /usr/lib/openmpi/lib are libopen-pal.so and libopen-pal.so.4.0.5.

What should I do?

Thanks

1 Answer 1

22

This solved it for me: sudo ldconfig

After that, I was able to run mpicc on Ubuntu 14.04

2
  • 2
    thx, it worked for me Mar 7, 2018 at 21:03
  • Works for me in Ubuntu 22.04, 7 years later! Jun 14, 2023 at 14:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .