0

i cant login to Ubuntu-gnome 15.10 when enable Nvidia VGA in prime setting. when enter password a black screen is show and then gdm login page show again. i install various version version of Nvidia driver but this problem not resolved. but it's work about a mouth ago. please help me!!!

    $lshw -C display 
     *-display UNCLAIMED     
       description: 3D controller
       product: GK208M [GeForce GT 740M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:07:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128)
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:31 memory:b5000000-b53fffff memory:c0000000-cfffffff ioport:6000(size=64)
0

Seems to be the graphics card driver issue. I had a similar one and got it fixed, you can refer to that here

Generally you should use the drivers from the official Ubuntu repositories. Because you are having problems, using the latest drivers might be better. Install the latest official stable NVIDIA drivers for the GEFORCE GTX 740M.

First uninstall the currently installed NVIDIA drivers. Boot the computer, when the GRUB menu appears ...

Highlight the Ubuntu menu entry and press the E key. Add nouveau.modeset=0 to the end of the linux line. Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1. Enter your user name and the password, then execute :

sudo apt-get purge nvidia*  
sudo reboot

Now install the latest official stable NVIDIA drivers. Boot the computer, when the GRUB menu appears ...

Highlight the Ubuntu menu entry and press the E key. Add nouveau.modeset=0 to the end of the linux line. Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1. Enter your user name and the password, then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-361
sudo reboot 

Note : Maybe it is explicitly necessary to select the NVIDIA adapter in BIOS. When you want to use drivers 361, adding the PPA is not necessary. In this case the terminal commands you have to perform are these :

sudo apt-get update
sudo apt-get install nvidia-361
sudo reboot

In case you have installed the nvidia driver from their site(*run) then uninstall it as per that instructions.

enter image description here

|improve this answer|||||
  • Tanks but it now work for me . Is there another way to remove run file changes? – mj rahati Feb 24 '16 at 17:34
  • before install nvidia driver run file i can use nvidia-352 driver with nvidia-prime – mj rahati Feb 24 '16 at 17:37
  • Go to the directory which contains that executable and execute it...and then follow the on screen instructions to uninstall the prop* nvidia driver and then execute the following instructions as mentioned in the answer – Ashu Feb 24 '16 at 17:39
  • Why nvidia-319? It is wrong. – Pilot6 Feb 24 '16 at 21:27
  • @Pilot6 added the screen shot from nvidia website...even i am wondering about it as it should be 352 or 358 or 361 but let OP try out – Ashu Feb 24 '16 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.