I'm running 15.10. Yesterday I had a message that there were updates available and I upgraded. Among the updates was kernel 4.2.0-30-generic. It wanted to restart but I chose restart later. This morning when I turned on the machine I went through the grub menu normally (Windows is also installed) and it booted to a black screen and stopped before the splash screen and login. From the black screen I can't CTRLALTF1 or do anything really and there is no disk activity. From looking at syslog, it seems that the system time was wrong, but other than that, everything seems to have loaded properly, it just never got to the login screen. I restarted after a while and went through the grub menu to recovery mode and ran some of the diagnostics which didn't find anything except the system time. I let it continue with normal boot and it booted fine. Once logged in, I ran apt-get update/upgrade/autoremove/dist-upgrade/clean and rebooted. Tried the default option and it booted to the same black screen. Tried kernel 4.2.0-30 (upstart) which froze. Tried 4.2.0-27-generic which boots no problem. I tried to run grub-script-check -v from the terminal but it didn't do anything and I eventually had to ^C. I've never tried to run it before but I would imagine that it shouldn't take too long. The man page said it just checks the config file for syntax. What do I do? Uninstall/Reinstall kernel 4.2.0-30?

  • 1
    Uninstall 4.2.0-30 and boot with 4.2.0-27. It is a bug. – Pilot6 Feb 24 '16 at 13:28

Kernel 4.2.0-30 has a bug. Uninstall it by issuing the following commands in the terminal.

sudo apt-get remove linux-image-4.2.0-30-generic
sudo update-grub2
  • 1
    There is no need to update grub. It will be run either way. – Pilot6 Feb 24 '16 at 18:34
  • When uninstalling, a message was displayed advising me to update grub... – JB0x2D1 Feb 24 '16 at 18:35
  • Well, each linux-image uninstall triggers update-grub. But that's OK. – Pilot6 Feb 24 '16 at 18:38

It seems the Linux Kernel version 4.2.0-30 has a bug and is currently being fixed. See this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1548587

A temporary solution (until the bug is fixed) was to remove the version 4.2.0-30 kernel. This should revert you back to whatever the last version that was working. The command below worked for me:

apt-get --purge remove linux-image-4.2.0-30-generic linux-image-extra-4.2.0-30-generic

For reference, both versions 4.2.0.27 and 4.2.0.25 worked for me without a problem

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.