0

I have Ubuntu Gnome 15.10 up to date and Chrome Version 48.0.2564.116 (64-bit). Gnome names my monitor as "secondary display" and TV as "primary display". TV is on the left hand side and monitor on the right. When I open Chrome, it always opens in primary display. That is really annoying, as it is a TV and usually off or used as a TV. I always have to Super+Shift+Right arrow to get Chrome to my monitor. The window that asks for password when I open Chrome opens in my monitor. I have several profiles in Chrome, they all open in secondary display.

How do I control where Chrome opens?

  • Good question - which means it's difficult to answer! If setting the monitor as primary is something you don't want (because of the other profiles?), there may be some help on this page, though I can't guarantee it. askubuntu.com/questions/9921/… – theodorn Feb 24 '16 at 9:55
  • I got the monitor set to primary, but it is now number 2. TV is number 1, but I do not know if it makes any difference. I disabled TV and opened and closed chrome, also booted, no help. – Ohto Nordberg Feb 24 '16 at 18:13
  • I don't know what you can do, then. I just plugged my laptop to my TV, and both the laptop screen and the TV had settings for being chosen as a primary display. I set the TV as primary, opened Firefox, dragged it over to the laptop screen, and closed it. When I started Firefox again, it appeared on the primary display (the TV) which I think is the default behaviour. – theodorn Feb 24 '16 at 18:58
  • One more thing, do you have a setting which says Configure new displays when connected? If so, have you tried checking or unchecking it? – theodorn Feb 24 '16 at 19:01
1
  1. After boot, open Chrome.
  2. If it asks for password, give it.
  3. Move Chrome to desired position.
  4. Close Chrome.
  5. Open Chrome

Now it does not ask for password and opens in desired position. If you have more profiles, open all, move them and close them. Next time they will open in the same position.

0

This is very annoying, when you might be connect to a turned off monitor, but do not intend to use it... One solution that worked for me is- Right click on the tile bar of the application Then choose "Move to Screen" option Select your monitor Close the application and try reopening it again to test. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.