I changed the /etc/default/grub file to the following:


and also /etc/grub.d/30_os-prober file to the following:

if [ "\${timeout}" = 0 ]; then    
  set timeout=0

My problem is the following: i wanted the GRUB_DEFAULT to start up Ubuntu, but the problem is that GRUB_DEFAULT=3 points to a windows test memory startup, and with the other modifications, the GRUB2 menu screens skips and goes directly to that partion (Windows Test).

I need to find a way to edit the Ubuntu /etc/default/grub and set GRUB_DEFAULT=3 to GRUB_DEFAULT=1 or a way to see the GRUB MENU on startup.

Holding shift after boot doesn't work. Any ideas?

  • If the problem is that you can't boot into Ubuntu to edit the files, and if you're booting in EFI mode, try using the USB flash drive or CD-R version of my rEFInd boot manager to boot into Ubuntu on a one-time basis. You should then be able to edit your GRUB configuration and do a sudo update-grub to fix the problem. Alternatively, you could boot an Ubuntu live CD; however, the process for updating GRUB will either be more complex (and therefore error-prone) or involve Boot Repair (which can have unintended side effects). – Rod Smith Feb 21 '16 at 15:38
  • Escape key with UEFI normally gets you to a grub menu. But if you have fast boot (not Windows fast start up) on in UEFI you may have to be very quick or it may only work from total cold boot. Or some have to turn off UEFI fast boot to be able to press a key on boot. Do you have multiple Ubuntu installs? or why is not entry 0 as default not the one you want? – oldfred Feb 21 '16 at 15:56

/etc/default/grub and files in /etc/grub.d/ are template files which decide how the update-grub command creates the grub configuration files. You can edit the files in [boot partition mount point]/grub/grub.cfg from another OS which can read the /boot filesystem (usually ext4) including live systems which you start from USB. Just mount your /boot filesystem under [boot partition mount point] - in doubt which one is the right one check /etc/fstab, find the UUID for /boot and mount UUID=[UUID] /mnt/boot (then edit /mnt/boot/grub/grub.cfg).

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.