4

Some of the fonts on popular web sites (like Facebook) have changed since I reinstalled 14.04 LTS. I'd only originally had it installed for about a week, and the fonts seemed normal. But since reinstalling some of the fonts have changed to something less easily readable.

Old (better) font:

New (worse) font:

How do I change the font back, or what might have changed it? I have the Unity Tweak Tool installed and the fonts on their default settings (as they were before reformat). Could it be ttf-mscorefonts-installer? Because I'm not sure if that was installed on my last go-around.

Edit: Sorry, completely forgot to mention, the web browser is Chromium in both cases.

  • 1
    Right click and inspect the element. In the Computed tab, look for the font-family, and at the bottom, Rendered Fonts. Post them both here. – muru Feb 26 '16 at 3:24
  • When I inspect the element, I don't see a Computed tab, but in the Styles section I can see the line: font-family: helvetica, arial, sans-serif Then further down, there's a line that reads font-family: 'lucida' but this has a line through it. – Soundscape Feb 27 '16 at 22:15
  • Does it look the same in Firefox or is it Chromium issue? Relevant package versions? – Jakuje Feb 27 '16 at 22:21
  • In Firefox, the font is the same, but is much taller and more readable. Looking side-by-side with Chromium, Chromium looks stretched horizontally in comparison. Note: This is not a zoom issue. Both are at 100% zoom, and other fonts on the page appear identical. Only this particular font appears different between the browsers. Chromium: Version 48.0.2564.116 Firefox: Version 44.0.2 – Soundscape Feb 28 '16 at 0:21
  • font-family lists fonts in the order of precedence. You've mentioned MS Core Fonts package. It may have caused this: when you installed ttf-mscorefonts-installer, its fonts become more preferable than sans-serif. Try uninstalling this package, reboot and recheck. – whtyger Feb 28 '16 at 15:34
4
+200

Font substitutions for your case are described in the file /etc/fonts/conf.avail/30-metric-aliases.conf. It looks complex at the first glance, but it is pretty logical.
Your "better" font is Liberation Sans and it replaced Helvetica and Arial everywhere, until you installed ttf-mscorefonts-installer. Now Arial appeared in your system and it is more preferable than Liberation Sans, according to the substitution rules (they can be found in the "Map generics to specifics" section of the mentioned file).
You can override these rules with your personal rule file. Create the file with the name local.conf somewhere and put the next lines in it:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

<!-- Map generics to specifics (overrides 30-metric-aliases.conf) -->

    <alias binding="same">
      <family>Helvetica</family>
      <accept>
      <family>Liberation Sans</family>
      </accept>
    </alias>

</fontconfig>

Now copy it to the folder with the font settings:

sudo cp local.conf /etc/fonts

Reboot and check whether your "better" font has replaced the "worse" one.
NB This trick replaced only sans-serif font, but it can be used to set the precedence of the serif and monospaced fonts at your desire.

2

This was solved by performing a complete uninstall of ttf-mscorefonts-installer and restarting the system, per whtyger's suggestion.

  • And now, when we've found the source of the trouble, we can re-install ttf-mscorefonts-installer and try to fix your fonts issue. – whtyger Feb 29 '16 at 7:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.