5

How can I set the default terminal emulator? Preferably from the command line.

I am running Ubuntu 14.04.03, and Unity and Lubuntu desktops

5
sudo update-alternatives --config x-terminal-emulator

Should run something like:

$ sudo update-alternatives --config x-terminal-emulator

There are 7 alternatives which provide `x-terminal-emulator’.

Selection Alternative
———————————————–
    1 /usr/bin/xterm
    2 /usr/bin/uxterm
    3 /usr/bin/koi8rxterm
    4 /usr/bin/lxterm
*+ 5 /usr/bin/gnome-terminal.wrapper
    6 /usr/bin/konsole
    7 /usr/bin/xfce4-terminal.wrapper

Press enter to keep the default[*], or type selection number:
| improve this answer | |
2
sudo update-alternatives --config x-terminal-emulator

recommended here, here, and here seems to work.

| improve this answer | |
  • 1
    ur answer is essentially a referral to another question, it would be better to flag this question as a duplicate of the other (with the [flag] button below this one). – David Foerster Feb 21 '16 at 11:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.