Using version 14.04 LTS. I've been using Duplicity to back up my home directory (/home/user) to an external hard drive (/media/user/Backup). I've just reinstalled 14.04 LTS. Now I want to restore my home directory to what it was before the reinstall.

I've tried using the gui "Backup" - choosing the last backup date to restore from and "restore to original folders" - this doesn't work. There is no change to my reinstall home directory. All I've noticed is that there is a lock symbol on my /home and /home/user folders after I tried this.

Is what I'm trying to do possible? If yes, how do I do it?

  • 1
    Yes has to be possible. That is the whole idea of a backup and would be a serious flaw if not possible. You probably are doing something wrong (though it is totally not clear to me what). Possible thing to consider: did you use the same username for old and new system?
    – Rinzwind
    Feb 22, 2016 at 20:32
  • Please answer above and add whether you used encryption on the back-up files or not.
    – Fabby
    Feb 23, 2016 at 19:39
  • Hi, yes same username. Don't think I encrypted backup, but I need to check that. How would I do that?
    – Curt Goff
    Feb 23, 2016 at 22:04
  • To check if the backup is encrypted go to the backup directory and take a look into the last duplicity...............difftar.gz file. if you can unpack and antar it, than you didnt use a passwort for the backup.
    – cmks
    Mar 13, 2016 at 16:01
  • 2
    You should definitely try to restore to a different folder and have look at the file information. Maybe your UID changed from the old install to the new one.
    – Björn
    Jul 8, 2016 at 12:24

1 Answer 1


It's likely that the UID (the number behind your user name) has changed.

You'll probably need to find out the old UID (maybe it can be retrieved out of the backup somehow) and change your current user name's ID to the old number. Further information on how to do that is available in this question: How can I change my own user ID?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.