2
  • GPU: Nvidia (BFG) 8800 GTS 320Mb
  • Monitor: Acer 22"
  • Max resolution supported by the GPU: 2560x1600
  • Max resolution supported by the monitor: 1680x1050
  • Resolution stuck at: 1152x864

I have spent almost two weeks so far trying to fix this resolution limit issue on Ubuntu 14.04:

  1. I have gone through any result that comes up in Google in the first five pages
  2. I have read at least 10-15 topics on this forum alone, and many more on other websites
  3. I have tried the xrandr trick
  4. I have tried the xconfig file trick
  5. I have tried updating/reinstalling/uninstalling Nvidia drivers
  6. Tried different versions of the Nvidia driver (official/unofficial/open-source/latest version/older versions)
  7. checking the monitor plug, etc

NONE of these have worked at all. I have reinstalled my Ubuntu 14.04 three times (every time a completely clean install, formatting the "entire" hard disk), I even tried 15.10, Linux Mint, elemntaryOS, Korora, etc - since I thought the problem is only with Ubuntu, but I have the same problem on all these distributions.

I do not have this resolution limit problem on Windows at all, it is only on Ubuntu. I can go up to 1680x1050 on Windows.

It is so mental, and I have spent hours and hours trying any possible fix that I have found online, and absolutely nothing has worked.. Does anybody know any fixes for the issue?

Nvidia X Server shows this

  • The screenshot says, "CRT-0" which implies that the monitor is connected through a VGA cable, I would recommend any digital cable (DVI, HDMI, DP) over VGA. If that is not available try a new VGA cable that has not been bent much or is very flimsy. Through recent experience I know that VGA can support up to 1920x1200 but not all cables at all time in their lifecycle. – LiveWireBT Feb 21 '16 at 11:44
  • Yes, it is true that I am using a VGA cable to connect the monitor to my GPU. However, since my GPU does not support VGA cables, I am using a VGA-DVI adapter. But one thing to note is that, using the same adapter and configuration I was able to get the desired resolution in Ubuntu 11.10 back in the day.. – l.. Feb 21 '16 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.