So this all started with that most recent libnl-3 update that occurred and crashed or stalled out most peoples network managers about a week ago. I understand I had proposed checked, stupid me, anyway I tried to downgrade those files (libnl, libnl-route and libnl-gen) anyway things were looking good. Until I restarted my computer. Not my keyboard will not work at the main log in screen, nor in recovery mode no matter which kernel I choose to use. Also mouse and keyboard does not work in recovery mode to select options.

selected every generic kernels but no avail. Help is seriously awaited. dont wanna loose data as its my work comp.

Thank you


This post doesn't ask a clear question, but the title is exactly what happened to my machine, albeit running ubuntu 16.

I had upgraded, and while the box booted to the lightdm login screen, keyboard and mouse (laptop internal, also I tried plugging in usb) were non-responsive. After a time the cursor in the password field stopped blinking as well.

It appears some X packages had been incorrectly deleted when i ran an apt autoremove (necessary due to a full /boot drive).

re-installing apt install xserver-xorg-input-all fixed the issue for me.

(to install this, boot into recovery mode, enable networking, and drop into the root shell. When completed, reboot.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.