3

Ubuntu 14.04.4 LTS kernel 3.19, xorg 1.17 (vivid HWE stack)

sudo apt-get install libsdl2-2.0-0:i386

gives the following output. This can't be right! I need this for pcsx2 1.4.0

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libglew1.10:i386 libusb-0.1-4:i386 linux-headers-3.19.0-25
  linux-headers-3.19.0-25-generic linux-image-3.19.0-25-generic
  linux-image-extra-3.19.0-25-generic linux-lts-vivid-tools-3.19.0-31
  linux-signed-image-generic linux-tools-3.19.0-31-generic nvidia-cuda-gdb
  opencl-headers
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libegl1-mesa libegl1-mesa:i386 libegl1-mesa-drivers libgbm1:i386
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libopenvg1-mesa
  libwayland-egl1-mesa libwayland-egl1-mesa:i386 xserver-xorg
  xserver-xorg-core xserver-xorg-input-evdev
Suggested packages:
  libglide3 libglide3:i386 xfonts-100dpi xfonts-75dpi
The following packages will be REMOVED:
  libegl1-mesa-lts-vivid libegl1-mesa-lts-vivid:i386 libgbm1-lts-vivid
  libgbm1-lts-vivid:i386 libgl1-mesa-dri-lts-vivid
  libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid
  libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid
  libglapi-mesa-lts-vivid:i386 libgles1-mesa-lts-vivid libgles2-mesa-lts-vivid
  libwayland-egl1-mesa-lts-vivid libxatracker2-lts-vivid
  xserver-xorg-core-lts-vivid xserver-xorg-input-all-lts-vivid
  xserver-xorg-input-evdev-lts-vivid xserver-xorg-input-mouse-lts-vivid
  xserver-xorg-input-synaptics-lts-vivid xserver-xorg-input-vmmouse-lts-vivid
  xserver-xorg-input-wacom-lts-vivid xserver-xorg-lts-vivid
  xserver-xorg-video-all-lts-vivid xserver-xorg-video-ati-lts-vivid
  xserver-xorg-video-cirrus-lts-vivid xserver-xorg-video-fbdev-lts-vivid
  xserver-xorg-video-intel-lts-vivid xserver-xorg-video-mach64-lts-vivid
  xserver-xorg-video-mga-lts-vivid xserver-xorg-video-neomagic-lts-vivid
  xserver-xorg-video-nouveau-lts-vivid xserver-xorg-video-openchrome-lts-vivid
  xserver-xorg-video-r128-lts-vivid xserver-xorg-video-radeon-lts-vivid
  xserver-xorg-video-savage-lts-vivid
  xserver-xorg-video-siliconmotion-lts-vivid
  xserver-xorg-video-sisusb-lts-vivid xserver-xorg-video-tdfx-lts-vivid
  xserver-xorg-video-trident-lts-vivid xserver-xorg-video-vesa-lts-vivid
  xserver-xorg-video-vmware-lts-vivid
The following NEW packages will be installed:
  libegl1-mesa libegl1-mesa:i386 libegl1-mesa-drivers libgbm1:i386
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libopenvg1-mesa
  libsdl2-2.0-0:i386 libwayland-egl1-mesa libwayland-egl1-mesa:i386
  xserver-xorg xserver-xorg-core xserver-xorg-input-evdev
0 upgraded, 18 newly installed, 41 to remove and 11 not upgraded.
Need to get 13,7 MB of archives.
After this operation, 35,5 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

also filed a bug: https://bugs.launchpad.net/ubuntu/+source/libsdl2/+bug/1547812

Any suggestions/workarounds?

EDIT:

apt-cache depends libsdl2-2.0-0:i386
libsdl2-2.0-0:i386
  Depends: libasound2:i386
  Depends: libc6:i386
  Depends: libpulse0:i386
  Depends: libwayland-client0:i386
  Depends: libwayland-cursor0:i386
 |Depends: libwayland-egl1-mesa:i386
  Depends: <libwayland-egl1:i386>
    libwayland-egl1-mesa:i386
    libwayland-egl1-mesa-lts-utopic:i386
    libwayland-egl1-mesa-lts-vivid:i386
    libwayland-egl1-mesa-lts-wily:i386
  Depends: libx11-6:i386
  Depends: libxcursor1:i386
  Depends: libxext6:i386
  Depends: libxi6:i386
  Depends: libxinerama1:i386
  Depends: libxkbcommon0:i386
  Depends: libxrandr2:i386
  Depends: libxss1:i386
  Depends: libxxf86vm1:i386
  PreDepends: multiarch-support:i386
    multiarch-support
  Conflicts: <libsdl-1.3-0>
  Conflicts: <libsdl-1.3-0:i386>
  Replaces: <libsdl-1.3-0>
  Replaces: <libsdl-1.3-0:i386>
  Replaces: libsdl2-2.0-0
  Breaks: libsdl2-2.0-0

EDIT2: removing bug report!

  • Is libwayland-egl1-mesa-lts-vivid:i386 installed? – Pilot6 Feb 20 '16 at 14:00
1

The problem is with HWE.

Run first

sudo apt-get install libwayland-egl1-mesa-lts-vivid:i386

Then try again.

  • unfortunately, i already have those installed, so it did nothing – philsegeler Feb 20 '16 at 13:31
  • Are you sure that these 32-bit packages are installed? It is a bit tricky to figure out all these dependencies with these HWE packages. – Pilot6 Feb 20 '16 at 13:36
  • edited my answer to post output. – philsegeler Feb 20 '16 at 13:41
  • I updated the command. If that does not work I will look into it. – Pilot6 Feb 20 '16 at 13:47
  • all of them are already installed as well! – philsegeler Feb 20 '16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.