26

I have VLC 3.0.0 installed on my Ubuntu 15.10 PC. VLC does not display video properly in full screen.

Windowed mode: enter image description here

Full Screen: enter image description here

I have tried reinstalling VLC, removing VLC completely using purge & then installing, removing VLC using Synaptic & then installing, but this issue remains. Any solution? Note: I used to be able to use VLC fine some time ago, this issue just came randomly..

  • Right click on the fullscreen mode>Video>Always adapted to the window. Is it checked? Please note that the last VLC version stabily supported by Ubuntu is 2.2.1.3 (last one in official repos). If you installed your 3.0.0 from an external repository, you have to report the bug there. – dadexix86 Feb 20 '16 at 9:07
  • Actually, the option is Always Fit to Window(in my installation, anyway) and yes, its checked. I have installed VLC from ppa:videolan/stable-daily. I used to have VLC 2.2.1 and faced the same problem, so I removed it and installed 3.0.0..I don't think this is a bug in 3.0.0 as I had the same issue with previous versions... – mayank budhwani Feb 20 '16 at 9:26
  • There is a problem with qt5 at the moment, have a look here: linuxquestions.org/questions/slackware-14/… – andrew.46 Feb 21 '16 at 5:53
  • How do I apply the patch? Sorry if this is obvious, I am a newb.. – mayank budhwani Feb 21 '16 at 7:24
48

In Tools > Preferences > Video > Output change to "OpenGL GLX video output(XCB)", save and restart vlc:

enter image description here

If you use Intel GPU, following setting speeds up decoding. In Tools > Preferences > Input/Codecs > Hardware-accelerated decoding chant to "VA-API video decoder via X11":

enter image description here

  • 1
    It would be nice to have some references. But that worked like a charm! – colidyre Nov 24 '16 at 20:54
  • With Ubuntu as Vmware client it worked when selecting "XVideo output (XCB)" as Video > Display > Output (first screen of the answer above). – Jocelyn May 16 '18 at 7:18
0

I had this problem as soon as i disabled my video card. Tried many things but none worked. The first thing i noticed after disabling my video card is my screen resolution changed. So i changed it from 800*600 to 1024*768 and played a video. To my amusement it was better than before. So i set it to 1280*1024 and its perfect now. I did it just now like 10 minutes back and immediately posting this so that this one might work for some people.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.