0

I tried to use the Kit Autocreator in the Devices tab, but the click ends with the following error:

Reading package lists...

Building dependency tree...

Reading state information...

build-essential is already the newest version. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ubuntu-sdk-libs:armhf : Depends: liboxideqt-qmlplugin:armhf but it is not going to be installed Depends: ubuntu-html5-container:armhf

E: Unable to correct problems, you have held broken packages. Command returned 100: schroot -u root -c source:click-ubuntu-sdk-15.04-armhf -- /finish.sh

There was an error creating the click target, cleaning up Traceback (most recent call last): File "/usr/bin/click", line 86, in sys.exit(main()) File "/usr/bin/click", line 82, in main return mod.run(args) File "/usr/lib/python3/dist-packages/click/commands/chroot.py", line 266, in run return args.func(parser, args) File "/usr/lib/python3/dist-packages/click/commands/chroot.py", line 68, in create return chroot.create(args.keep_broken_chroot) File "/usr/lib/python3/dist-packages/click/chroot.py", line 568, in create self.full_name, ret_code)) click.chroot.ClickChrootException: Failed to create chroot 'click-ubuntu-sdk-15.04-armhf' (exit status 100)

click target was removed successfully

---Click exited with errors, please check the output---

I've added the ubuntu-sdk-team repository and apt-get updated already, but there still seem to be some packages missing, ubuntu-html5-container:armhf in particular. I'm running the SDK as root, so it shouldn't be a permission issue either.

Any help is greatly appreciated.

1

The bug is a dependency issue on oxide :

https://bugs.launchpad.net/ubuntu/+source/oxide-qt/+bug/1543215

  • Thank you for the answer. For anyone else that has a similar issue, I had installed ubuntu-sdk-api-15.04-armhf already, but it somehow got corrupted. Running apt-get purge and apt-get install solved the issue. – Brett Haines Feb 22 '16 at 13:49
  • For anyone else looking at this I had this issue because I chose 15.04 instead of 14.04 which was my OS version – ShaneQful Apr 23 '16 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.