2

I'm trying to connect a Microsoft Bluetooth Mobile Mouse 3600 in Ubuntu 15.10.

I first tried connecting through unity-control-center. This would discover the device, but fail to connect every time. On further research, it seems it's not possible to connect to a LE (low energy) device this way.

So I tried it with CLI tools. I can get this far:

$ sudo hcitool lescan
LE Scan ...
F2:C2:08:8A:DD:10 BluetoothMouse3600
F2:C2:08:8A:DD:10 (unknown)
sudo gatttool -I
[                 ][LE]> connect F2:C2:08:8A:DD:10 random
Attempting to connect to F2:C2:08:8A:DD:10
Connection successful
[F2:C2:08:8A:DD:10][LE]>

So it seems the mouse is connected. However, it does not seem to be working as a mouse, at least when I move it, the pointer does not move. Also, hcidump does not show any activity when I move the mouse.

Is there something more I need to do to get it recognized as a mouse? Any more troubleshooting steps I might take?

  • Thank you for the post. I have the same problem for Ubuntu 14.04 LTS. Therefore i've adapted the question -- to avoid forum redundancy. Hope it is fine for you. Good day :) – alex Mar 1 '16 at 11:43
  • this (answer from Chris McCormick) worked for me. – alex Mar 1 '16 at 14:07
2

After a few false starts I have Microsoft Bluetooth Mobile Mouse 3600 working on a Dell XPS with Ubuntu 14.04. I took the advice in Logitech MX Master Mouse pairs, but won't work and installed Bluez 5.41

Using bluetoothctl I was able to pair and 'trust' the mouse. On my first attempt the mouse would work fine for a few minutes, then I'd need to power off and power on bluetooth using hciconfig hci0 down; hciconfig hci0 up

Eventually I figured out that I had two entries for the mouse in /var/lib/bluetooth/XX:YY:ZZ..... Once I wiped out the contents of that directory and started over, pair, etc. all was fine.

1

I have a Dell Inspiron 5557, running Ubuntu 16.04. I have detected, paired and I'm using this mouse, without any package or configuration.

The only trick that I really needed was to push and hold the power button of the mouse some seconds (It turns on a green light behind the mouse) and detect and pair the mouse with blueman. I just was able to do this after use this trick.

  • After dabbling with command line for a few hours, this (installing blueman and adding the mouse there) worked for me on Ubuntu 16.04. Tks. – Hugo Jul 16 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.