1

A few days ago I received my new laptop: Dell XPS 13 9350 (late 2015 model, also known as 2016 model). With quite some effort I was able to dual boot windows and linux, namely by setting AHCI through bios, reinstalling Windows (so it works with AHCI) and then installing Ubuntu (Gnome). Both are installed UEFI.

However, I have some persistent problems with my linux-install that I can't seem to fix by googling previous used solutions. Problems I'm having are:

  • No wifi (doesn't show up in additional drivers either)
  • No shutdown/reboot. It will hang in shutting down, so I have to cold-hardware-button-shutdown my pc and then boot it again whenever I want to reboot.
  • No hibernate/standby. When I close the lid of my laptop, it won't go in standby/hibernate. When I open it up again, the screen is black though, but it won't get out of that black screen, so I have to hardware-button kill it again.
  • Can't seem to upgrade to kernel 4.4 (from 4.2). Tried it a few times, but it wouldn't boot to 4.2. I had to reboot, choose advanced options in GRUB and remove 4.4 again.

If anyone can solve any of these problems I would be immensely grateful. I'm willing to change linux-version if that could fix things. This laptop is mainly intended as a dev-laptop, but without linux that's not really working out for me.

Thanks in advance to any and all help!

Greets, Rien

EDIT: I can now succesfully install another kernel. It's now running on the 4.4-kernel. But wifi is still not working, nor can I shutdown my computer. Part of dmesg gives me the following: wl: module verification failed: signature and/or required key missing - taining kernel and also kernel BUG at include/net/cfg80211.h:3574! Any and all help is still most welcome!

  • Please ask one question at a time. – Pilot6 Feb 19 '16 at 14:56
3

I was finally able to fix all of the above problems and run linux succesfully on this device.

The 'solution' is a bit tricky though: I simply formatted my linux partition and installed it all over again, this time with Unity (instead of GNOME). After installing I found that reboot/shutdown already worked and the touchpad seemed to be better too. I then installed the 4.4.2 kernel succesfully and all of a sudden wifi was working and so was suspending. From Unity I then installed GNOME and now I have a working Ubuntu install with GNOME.

  • How is the battery life in Linux? Can you make it default-boot to Linux instead of Windows? – Axonn Jul 13 '16 at 12:48
  • 2
    Yes, my grub is set to default boot to Linux. Battery life is pretty good, I think about 8 hours on a single charge for me. – Rien Heuver Jul 17 '16 at 18:44
  • I just got my 9350 :). Trying to install Ubuntu now. What version did you go for? – Axonn Aug 2 '16 at 14:20
  • 1
    Exactly as explained in my self-answer – Rien Heuver Aug 2 '16 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.