2

I installed standard Ubuntu 14.04 LTS about a fortnight ago and everything has been working fine. Yesterday I installed Wine via the standard package manager and then installed a simple windows exe WBridge5 (using wine) and then ran it a couple of times using wine and all was fine. Note that this may be irrelevant.

Today I started my DELL Inspiron 6400 and after entering my password the standard desktop appeared without my previously set background; the file mgr appears automatically (without the recent files icon) and the following message appears:

"Oops! Something went wrong. Unhandled error message: The name org.gtk.vfs.Daemon was not provided by any .Service files."

After acknowledging the message, my programs operate but WITHOUT a text menu showing on the top menu bar. There are other minor inconveniences such as Alt+Tab doesn't work and there is no "Recent" option on the Files program and "System Settings Appearance" cannot be changed. The show stopper for me is that unless a program has a non text menu method of running a menu option, you are stuffed. This affects Libreoffice really badly.

I have searched the web for the error message above and tried various remedies, including uninstalling wine and removing ubuntu-desktop and reinstalling it using dpkg. No success or change to desktop behaviour.

sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install --reinstall unity

Now logged as an Ubuntu bug. See:

https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1548841

Following the following actions, the bug is now largely fixed but a few problems remain. (see below)

I removed and reinstalled the unity, compiz and then gconf packages e.g.

sudo apt-get purge unity
sudo rm /usr/share/dbus-1/services

The package removal process was not simple as there were lots of problems including the usual messages about dependencies and a number of messages about not being able to remove /usr/share/dbus-1/services files.

The situation now is that the window text menus now appear and Alt+Tab switches between windows.

Not quite clear what has fixed this - was it the reinstall or the removal of the dbus-1 directory. The following problems still exist:

  • Changes to System Settings Appearance don't save and existing ones take no effect, e.g. bland system background displays.
  • Unable to start the Terminal app. Ctrl+T does nothing. Ctrl+Alt+F1 continues to work fine.
  • The org.gtk.vfs message still appears at session start up.
  • Rubbish Bin AND Browse Network are NOT working on the Files app and the org.gtk.vfs message displays.
  • Ubuntu Software Center does not start.
  • The message is that systemd .service files didn't provide the service. Interestingly, I didn't find any ubuntu package that would provide a …vfs….service file. But just a blind guess: try to open a terminal (since you have problems, you can just switch between a terminal and graphical sessions with «Ctrl+Alt+F1/F7»), and try to enter sudo service gvfsd start and sudo systemctl start gvfsd. If they both would print errors about a missing service, try to run it manually /usr/lib/gvfs/gvfsd. Ah, I think you have to try it before you entered the password to enter the graphical session. – Hi-Angel Feb 20 '16 at 0:54
  • Many thanks @Hi-Angel, when I run /usr/lib/gvfs/gvfsd I get the following error: "Failed to connect to the D-BUS daemon: cannot auto launch D-BUS without X11 $DISPLAY (g-io-error-quark, 0)". Then no change to the desktop behaviour. Regards.............. Peter. – Pander Feb 20 '16 at 11:35
  • 1
    @Hi-Angel I put the system log in the main topic text yesterday. I don't know if you saw it. I think that dconf is not starting/operating correctly for me. Maybe its corrupted. I am unable to install lumbuntu and gnome-session because I get dconf problems. I am also not able to amend anything with the gconf tool. conftool GconfWARNING Client failed to connect to the D-BUS daemon The message when I start unity seems to be about gvfs, see : wiki.gnome.org/Projects/gvfs/doc No idea where to go next. I will probably raise a Unity bug if we don't solve the problem soon. Thanks........ Peter. – Pander Feb 23 '16 at 12:35
  • 1
    Yeah, I didn't see that. Sorry, I took a look at the log, and have completely no idea what to do further, my eyes couldn't catch hints of what could happened. Interestingly, your question have too much views — assuming that the question felt down under other questions long ago, it seems that you're not alone with that problem… – Hi-Angel Feb 23 '16 at 18:25
  • 1
    @Hi-Angel, many thanks. As indicated, I have now raised an ubuntu bug. See >bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1548841 Many thanks....... Peter. – Pander Feb 23 '16 at 18:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.