2

I'm a newbie migrating from Windows coding to Ubuntu, but once I logged onto my machine there was this error with dpkg which is preventing me from installing any packages. I might have messed up while installing previous packages and etc.

I'm using Ubuntu 15.10 btw.

    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    root@lucas-G750JX:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      dpkg update-notifier update-notifier-common
    The following NEW packages will be installed:
      dpkg
    The following packages will be upgraded:
      update-notifier update-notifier-common
    2 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
            Need to get 0 B/2.297 kB of archives.
    After this operation, 6.770 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Could not exec dpkg!
    E: Sub-process /usr/bin/dpkg returned an error code (100)

Tried to imput ls -l /usr/bin/

   root@lucas-G750JX:~# ls -l /usr/bin/dpkg
   ls: cannot access /usr/bin/dpkg: No such file or directory

Any tip on how to solve this?

2
  • Please edit your question to include the output of command ls -l /usr/bin/dpkg. What were you doing recently that you think may have messed up? – steeldriver Feb 18 '16 at 23:12
  • I was trying to solve the problem "No such file or directory". On the forums I learned (or I think that I learned) that this problem happens due to the fact that my Ubuntu is a 64 bit version trying to run 32 bit stuff... So I tried to install the i386 libraries. – Lucas Ansei Feb 18 '16 at 23:24
3

Your system lacks the essential package and program dpkg. Usually one would install missing packages with the package manager, but unfortunately dpkg is the package manager.

Considering that you seem to just have installed Ubuntu, I recommend that you re-install it, because that will be a lot easier than bootstrapping the package manager on the botched system.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.