On Windows it works fine with this setup, so it's an Ubuntu issue. I am running HDCP capable HDMI cables to an HDCP capable TV as a dual monitor from an HDCP capable graphics card.

enter image description here

  • 2
    Seems like probably an issue with Chrome on Linux. I'd suggest contacting Google's support for Chrome about the problem. – dobey Feb 18 '16 at 17:23
  • 2
    dobey: how do you know he is using Chrome? – Luís de Sousa Feb 19 '16 at 15:10
  • I think this was firefox? But I use both – Jonathan Feb 22 '16 at 17:29
  • @JonathanLeaders I'm going to guess this is a DRM problem. You can enable DRM in Firefox to see if that helps. – Nicomachus Aug 16 '17 at 15:17
  • Anyone found a solution yet? – Jyotman Singh Aug 20 '17 at 18:02

HDCP is a work in progress. I'm not sure about the status, but comparing the first patch of the RFC to the code of linux-4.13-rc6 I see it didn't land yet.

Stay tuned, I'm pretty sure the day HDCP get the whole stack from kernel through DRM (as in Direct Rendering Manager) to userspace up and running you'll see a big article on Phoronix. It's a slow work because of other things in priority, and because any kind of DRM (as in Digital Rights Management) have always been a subject of hot controversy.

  • Is it fair to say it is impossible at the moment then, to solve? – Jonathan Aug 25 '17 at 21:53
  • 2
    @JonathanLeaders as far as my knowledge goes, ATM it's impossible. – Hi-Angel Aug 25 '17 at 21:55
  • 1
    @JonathanLeaders to elaborate, reading the cover letter of RFC I see that HDCP requires kernel code, libdrm code, modification of display drivers, and userspace support. It's a lot of work, and I very doubt that I could miss so many news. The article also mentions Android as a target, this suggests there's no some secret proprietary solution either. So yes, I ran out of possibilities for HDCP to work, I'm pretty sure it's impossible at the moment. – Hi-Angel Aug 25 '17 at 22:06

The protected content would not be streamed over unprotected media. High-Bandwidth Digital Content Protection usually authenticated all devices in chain. So that include application->Display Driver->Graphics Card-> Serializer(on host side) -> deserializer(on display device side) -> Display Device. HDCP usually encrypt data when transferred over cables(HDMI etc). But software that renders data can request underlying device content protection status. So things can go wrong at lots of places.

Problem is most likely with driver of your display adapter/associate serializer. You can try to get latest graphics driver for display adapter and display monitor. Also how are playing video via desktop app or web browser?

Hope this helps

  • This is helpful, and describes the problem, but is missing a solution. But thank you for your help. I am playing via Chrome or Firefox – Jonathan Aug 25 '17 at 20:24

The only way to get Amazon HD video streamed was through the flash stream through Firefox using the HAL PPA this is the link to that:


I'm not sure if it still works because I don't use flash anymore

The html5 stream works but HD is not supported at this time. Although tv shows do come through in HD. Just not movies. Since I run linux exclusively the best solution for me: Buy a roku. A roku 2 is about 35 bucks on amazon and it will stream anything amazon, netflix, hbo, etc. If you need a QHD or UHD get roku premiere.

  • 2
    Alternatives to roku include amazon firetv and possibly the chromecast – Jonathan Aug 26 '17 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.