0

Someone help me.

This error appeared after I installed without wanting NGINX but had the ispconfig . I want to continue to use the ispconfig . It seems that something is on the port that it is listening .

  • Restarting web server apache2 AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:61 (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80 (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down AH00015: Unable to open logs Action 'start' failed. The Apache error log may have more information. no listening sockets available, shutting down [fail]
  • The apache2 instance did not start within 20 seconds. Please read the log files to discover problems

I am new to linux. HELP ME PLEASE :'(

  • Does your server already have nginx on it and you don't want it, or what? Your question is incredibly vague on this. – Thomas Ward Feb 18 '16 at 17:57
  • Nginx will bind to port 80 avoiding apache to use it, just remove nginx with sudo apt-get remove nginx, and try to restart apache with sudo service apache2 restart to see if everything works. – bistoco Feb 18 '16 at 18:04
0

netstat -an will show you if port 80 (http) is already in use, which the error suggests is the problem.

You can try edit apaches default config file:

/etc/apache2/sites-enabled/000-default.conf

Change <VirtualHost *:80> to <VirtualHost *:8080> then sudo service apache2 restart to see if it gives an error. If it works then you need to find what's configured to listen on port 80. Use your browser (on apaches computer) to look at http://127.0.0.1 and see if anything loads. http://127.0.0.1:8080 will be apaches default page if you configured it for 8080.

Another useful command ... apachectl configtest


You may need to check what other programs you have installed recently. Usually config files are located in /etc// and man <program name> e.g: man apache2 to see command options etc.

0

If I'm interpreting your quesiton right, you have 'nginx' on the system already. This will always consume your Port 80 process in its default setup.

Three options to fix:


(1) You want to keep NGINX, but have nginx run on a different port.

If you want to keep NGINX, then edit /etc/nginx/sites-available/default and change listen 80 to listen 8080, then run sudo service nginx restart.


(2) You want to keep NGINX on Port 80, and have Apache run on a different port.

Refer to Teoma's answer.


(3) You don't want to keep NGINX at all.

You can easily get rid of it, I think.

Run these commands in this order:

sudo apt-get remove nginx nginx-full nginx-common nginx-light nginx-extras nginx-core
sudo service apache2 stop
sudo service apache2 start

This should have Apache then load as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.