Preamble: Few years back I dropped my laptop, it subsequently failed to mount the sda1 disk. I recovered it mounting it with a live usb ubuntu distro. Ever since, my laptop has never been as smooth anymore.

Q: I am getting this warning message during update:

cryptsetup: WARNING: failed to detect canonical device of /dev/sda1

a view at /etc/fstab and /etc/crypttab shows:

$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro,user_xattr 0       1
/dev/sda5       none            swap    sw              0       0


$ cat /etc/crypttab
# <target name> <source device>     <key file>  <options>

I am on ubuntu 14.04 LTS, uname -a shows

$ uname -a
Linux alessio-laptop 3.13.0-77-generic #121-Ubuntu SMP Wed Jan 20 10:50:59 UTC 2016 i686 i686 i686 GNU/Linux

I have been looking at other posts, but I am concerned with the errors=remount-ro and none tags in the fstab file. I am also pretty sure my disks are not encrypted.

Is this affecting the performance of my system, or even causing bigger errors? How could I fix it?


errors-remount-ro means that if errors are encountered the partition will be mounted read-only in order to avoid damage so you'll have the opportunity to fix the problems. This usually happens when there are hard disk problems. Don't change this setting. I have done this once and it turned out to be a pretty bad idea.

none means in your situation 'no mount point'. So /dev/sda5 which is your swap file as indicated in the column 'type' is not mounted at all and the system is not using it. If your system is low on memory this might affect the performance otherwise you wouldn't probably notice it.


Recently my Ubuntu boots slowly. To resolve it, I researched and found the command update-initramfs -u and tried to run it, but it showed me the following error:

cryptsetup: WARNING: failed to detect canonical device of /dev/sda7

Thanks to the answer of Predato here, I've fixed the problem.


Note: It's obvious, but at steps describing below, you have to do what's related to your problem, e.g. to consider your own error message. What I mean from /dev/sdax below is your partition with that error, e.g. /dev/sda7.

From his answer:

Main source of the error is corrupted swap partition linking. First you need to get UUID of your swap partition. Just run blkid command.

Considering the error happened, run the command and copy the UUID of /dev/sda7. It's something in this format: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, where x is a hexadecimal number.

First make a backup:

sudo cp /etc/crypttab /etc/crypttab.back

Here, open file for editing:

sudo nano /etc/crypttab

Then, remove the line related to /dev/sda7. For me, I didn't find any lines contains or related to /dev/sda7, so I skipped.

Then, run sudo nano /etc/fstab and add a new line with this syntax:

UUID=your_copied_uuid none swap sw 0 0

Note (important): If a line with exactly copied UUID exists, don't do anything and don't edit anything. For instance, I edited the line related to /dev/sda7 by changing the ext4 to swap; then, on the next reboot, the boot failed (the problem is now solved).

As the last step, and I think the most important one, run sudo nano /etc/uswsusp.conf and change the following line:

resume device = /dev/sda1


resume device = UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

By doing these steps, your problem may be fixed. For me, the problem was fixed and no errors happened on running update-initramfs -u. Again, a special thanks to the answer by Predato.

Hope this helps someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.