3

It doesn't matter if gnome-terminal or xfce4-terminal is used, I got always some broken characters in my terminal window.

Terminal screenshot

Terminal screenshot - bigger font

Specs:

  • Ubuntu 15.10
  • Ubuntu Mono, UTF-8 encoding
  • ZSH

Any tips would be appreciated.

  • What locale are you using under Settings -> Language and Support? – Parto Feb 18 '16 at 8:00
  • English. Second one is german – onigunn Feb 18 '16 at 9:31
  • 2
    Looks like an escape sequence unrecognized by gnome-terminal, probably ESC k l if I see the screenshot correctly, but could you please increase the font size all the way to the maximum? What's your shell? (Looks like zsh perhaps?) That one seems to output this sequence before executing the command. – egmont Feb 18 '16 at 20:40
  • egmont see my updated post. – onigunn Feb 19 '16 at 7:42
  • Did you notice a pattern for the broken characters? For example does that always happen when running l? Maybe seeing the content of ~/.zshrc could be useful. – kos Feb 19 '16 at 7:45
1

I had the same problem on my build and your question was the only one showing the problem I was having.

I had added the following line to my .zshrc:

 export TERM=screen-256color

Commenting it out fixed my problem. I unfortunately don't understand the reasons behind the bug, but hoping knowing this is a step in someone else fixing a similar problem.

  • Yep, thats solved my problem too. – onigunn Oct 27 '16 at 13:31
1

This is a known bug: https://bugzilla.gnome.org/show_bug.cgi?id=403130

The solution "is practically impossible. The code ... is terribly complicated, I'm afraid to touch it."

1

I just want to add my two cents: Actually I solved the problem by uncommenting this line in .zshrc:

export LANG=en_US.UTF-8

It did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.