I'm trying to mount a NAS drive USB connected to my Netgear 4300 router with NO password using 14.04. I have tried several options in the fstab file (including the ones here https://wiki.ubuntu.com/MountWindowsSharesPermanently). Some of them don't work at all (device doesn't exist.etc...). The closest I get to make it work with fstab as

// /media/nas cifs       user=user,uid=1000,gid=1000,_netdev,auto,noperm,file_mode=0777,dir_mode=0777,umask=000,iocharset=utf8,sec=ntlm,rw    0   0

The results of sudo mount -a = Password for user@// What gives and where else can I find more info, please? I can get to all the folders using "Files".

  • Can you please clarify the issue you are having when you give the sudo mount -a command? If you can access the share, what is the problem? – Organic Marble Feb 18 '16 at 3:51
  • Thk u Muru. I was able to resolve the issue thanks to a link to mount.cifs (nothing better than reading the Manual). Sudo mount -a would return "provide password to is needed). Here is the final line that worked. // /media/nas cifs guest,uid=1000,gid=1000,file_mode=0777,dir_mode=0777,iocharset=utf8,rw 0 0 – br116 Feb 19 '16 at 0:42

For the Netgear folks with w Readyshare folder. the final line in the fstab file that worked:

// /media/nas cifs guest,uid=1000,gid=1000,file_mode=0777,dir_mode=0777,iocharset=utf8,rw 0 0 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.