1

When I try to install gcc-4.6 on Ubuntu15.10 (32bit edition) using apt-get, but I can't.

I tried it, but Ubuntu displayed these error messages:

$ sudo apt-get install gcc-4.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package g++-4.6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Where can I find "another source"?

  • 1
    Possible duplicate of Old version of gcc for new Ubuntu – muru Feb 18 '16 at 1:46
  • Haplo's answer will work too, you just need change the PPA entry to use trusty instead of wily. – muru Feb 18 '16 at 4:41
  • @muru thanks a lot. I'll try to write my own PPA if I have time to learn about PPA. :) – yukkie Feb 18 '16 at 4:50
2

I added 2 lines in /etc/apt/sources.list:

deb     http://archive.ubuntu.com/ubuntu/ trusty universe  
deb-src http://archive.ubuntu.com/ubuntu/ trusty universe

It seems to work fine. Solved.

1

I found this the PPA link is at the bottom. Not sure how safe this is but I've added random PPA's and had no issues.

  • I doesn't work in my environment. Aftest "sudo apt-get update" I got the error message below. W: Failed to fetch launchpad.net/~h-rayflood/+archive/ubuntu/gcc-upper/dists/wily/… HttpError404 E: Some index files failed to download. They have been ignored, or old ones used instead. I have installed 32bit versioin of Ubuntu 15.10 because of project restrictions. This error message seems to be end of support of older version 32bit gcc. Thanks! – yukkie Feb 18 '16 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.