I have just installed and set up my HP Elitebook 8440p with Ubuntu Gnome 15.10 64bit and Gnome 3.18 During the installation, everything went nice, while the laptop was docked and the lid was closed. I didn't experience any sudden suspend. Then, after installing the nvidia driver (nVidia NVS 3100m - Driver Version 340.96) and rebooting a couple of times, the laptop would suspend by it self. This was happening either during X loading (after the splash screen) either after gdm login (or even during) or either during a shutdown/reboot. Some times it suspends immediately after a wake up. Sometimes no screen is restored after a wake up (the laptop screen or the external one).

It's a frustrating situation. My previous Ubuntu Gnome 14.04 LTS install, didn't have this problem.

I did search as much as I could to find any solutions or suggestions, so this is what I've tried:

Created the file


with the following content

[Disable suspend (upower)]

[Disable suspend (logind)]

[Disable suspend when others are logged in (logind)]

So that the systems ability to suspend was disabled It wasn't effective...

Of course, I have tried many settings of gnome shell as well



...and also org.gnome.settings-daemon.plugins.power in dconf-editor

Also, I know that even when my system seems to run normal after successfully login in gnome, if I try to reboot or shutdown, nothing happens! It turns out that there is a suspend job running...

nikos@elitebook:~$ sudo reboot
Failed to start reboot.target: Transaction is destructive.

And here is the job

nikos@elitebook:~$ systemctl list-jobs 
JOB  UNIT                               TYPE     STATE  
2160 suspend.target                     start    waiting
2161 systemd-suspend.service            start    running
2165 anacron-resume.service             start    waiting

I can either reboot -f to reboot or cancel the job systemctl cancel 2161 and reboot normally.

Note that this problem occurs only while the laptop is docked and the lid is closed. On normal use, this problem is nonexistent.

I wouldn't mind disabling or removing system suspend completely from my system. What else can I try to solve this?

EDIT (NOT solved though)

Continuing my search, I found that I can edit /etc/systemd/logind.conf It cointained the variable #HandleLidSwitch set to suspend which I changed. Here is what my file looks like:


My problem still persists...


I've managed to fix it

I found a fix in this bug comment


It involves editing /lib/udev/rules.d/70-power-switch.rules

and adding this line

SUBSYSTEM=="input", KERNEL=="event*", ATTRS{name}=="* WMI hotkeys", TAG+="power-switch"

Maybe someone will find this helpfull someday ;)

  • Thanks, worked for me as well on Ubuntu 18.04 – helado Jan 4 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.