0

I have a Moto G (Falcon-xt 1033).

Recently I successfully flashed cm 13 nighly on my device, everything worked fine, used the phone a little while, then flashed supersu and device went into a boot loop.

I had removed rom zip files from device storage, so I am trying to push rom zip into my device via adb. But the adb does not detect my device(nor does my laptop- running ubuntu 14.04). I tried a bunch of things from from trying all ports to updating adb version to creating 51-android.rules file under etc/udev/rules.d/

The recovery my device used is cwm. I want to access the storage drive of my device either by adb or by any alternative to push the rom .zip and other files. How exactly can I go about solving this problem.

Results of command: adb devices

PLEASE HELP!

1

From my experience, it is generally a bad idea to flash supersu on a CM13 install, because supersu is already supported by CM13 (in the developer options, the "root access" item), and there are some know issues with doing so. Here are some things that I would try :

First, make sure USB debugging is on for adb. You can enable it in Settings > developer options > Android debugging. You can also try to enable root access for ADB. Boot into recovery and try "adb devices". If this does not work, you can try the following steps :

1- If you can detect your device in fastboot mode (fastboot devices), flash a new recovery (TWRP or clockworkmod).

2- Reboot into fastboot

3- Go into recovery

4- Try adb devices. If it works, format system, data, cache and reinstall everything (except supersu ;p).

If this does not work, I would suggest you flash the factory Motorola image from fastboot mode and then try steps 1-4 again.

If all fails, I would suggest consulting the associated page of your ROM on XDA.

  • Problem found. The MTP was disabled and I still don't know how. CWM recovery did not provide the option to enable it, so flashed TWRP. Enabled it, moved the appropriate zip files to storage, flashed and now am enjoying my cm13 :D – user3762742 Feb 18 '16 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.