1

Today I moved my PC from one case to another and therefore had to change my graphics card from the PCI Express x4 to the PCI Express x16. This caused Ubuntu to go into low graphics mode. I managed to fix this by reinstalling default drivers (which I have used before and it has fixed issues perfectly). However, when I tried to reinstall the proprietary drivers (by unpacking the zip and building) it caused the system to enter low graphics mode again. Upon fixing and rebooting, the system is in a login loop. I try to login, it hangs on the desktop background for about 5 seconds, flicks to a black screen for a second and then opens up the login page again (and replays the sound that happens on boot). I have entered the tty console and logged in. The fixes i have tried from various answers on this site are:

  • Reinstalling ubuntu-desktop
  • Resetting unity (using Unity Tweak Tool - this resulted in a cannot autolaunch D-Bus error)

My system is as follows:

  • OS: Dual boot Windows 8 and Ubuntu 14.04
  • Graphics Card: MSI Radeon 390
  • CPU: Quad-core i7-4770k
  • RAM: 16GB
  • Storage: 1TB into 2 partitions: 480MB (Ubuntu) 520MB (Windows 8)

How can I fix it?

  • If you're trying to launch unity-tweak-tool from a CLI virtual terminal, that error is probably to be expected I think. Something is preventing your desktop session from starting: did you look at the contents of your ~/.xsession-errors file? – steeldriver Feb 17 '16 at 19:47
  • uhh.. no. i ran one fix which involved removing an xauthority file. sorry but i dont know much about ubuntu despite it being my main OS – JellyWX Feb 18 '16 at 7:23
  • ok thx. im new to this forum so i dont really know what im doing @clearkimura – JellyWX Feb 19 '16 at 17:24
  • @Jelly It's alright, I have suggested an edit for you. Take a tour to learn how this site works in brief; It's a good place to start. – clearkimura Feb 20 '16 at 14:04
2

Managed to fix this issue: very simple actually. Here are the commands I ran:

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri
sudo rm /etc/X11/xorg.conf.o* /etc/X11/xorg.conf.0* /etc/X11/xorg.conf.f*
sudo rm -rf /etc/ati

Some of these were copied from a cchtml wiki page with a few edits placed in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.