I'm trying to install Xubuntu using Wubi, however, once I start the installer, it runs all the way through (on the Installing Xubuntu-11.10 page with the two loading bars), and it gets to "Remaining time approximately 0s". Then, it gives me an error in a message box:

An error occurred:

Error executing command
>>command=C:\Winows\sysnative\bcdedit /create /d Xubuntu /application bootsector
>>stderr=The boot configuration data store could not be opened.
The system cannot find the file specified.


For more information see the log file:
  • have you tried to run Wubi.exe as an Administrator? – rigved Oct 30 '11 at 5:18

Go to an administrative command prompt and run bcdedit. This will open your BCD store and output the contents. If it fails with the same exception message then your problem is that Windows needs to be told where the BCD store is. i.e. nothing to do with Wubi (which is what I believe).

To open an administrative command prompt click the Windows key, type cmd, then look above, right click on CMD.EXE and select Run as Administrator.

Refer to Issue 3 here for explanation and potential fix: http://support.microsoft.com/kb/2419286

Edit: more information and fix from the Microsoft support site


When you run Bcdedit /enum you get the following error: “The boot configuration data store could not be opened. The system cannot find the file specified.”

Look for the following registry key HKEY_LOCAL_MACHINE\BCD00000000

If we check under HKLM you will not find the key BCD00000000


If some 3rd party storage Disk or Storage Management software is installed it may bring all the volume without drive letter offline

Generally 100 MB partition is system partition which contains Boot configuration Database and does not have a drive letter assigned.


From an administrator command prompt (right-click CMD.EXE and choose Run as Administrator):

C:\Diskpart> List volume
C:\Diskpart> Select volume 1 (Considering this is 100 MB system partition)
c:\Diskpart> Online volume
C:\Diskpart> exit
| improve this answer | |
  • 1
    The link had the directions to fix it. – Bob Oct 30 '11 at 21:50

This might be bug 613288, in which case I would encourage you to subscribe to that bug and use the "This bug affects..." link near the top of the bug link to indicate you are affected. However, there are a couple things to try first, in case you are not experiencing that bug, which may solve your problem.

First, you should MD5 test the .iso image (if you downloaded and burned/wrote/mounted/extracted the .iso), to make sure it is not corrupted. See https://help.ubuntu.com/community/HowToMD5SUM. If this is Ubuntu 11.10 Oneiric Ocelot, then since the MD5 hashes for that version have so far not yet been added to https://help.ubuntu.com/community/UbuntuHashes, you'll have to use http://releases.ubuntu.com/oneiric/MD5SUMS or http://cdimage.ubuntu.com/xubuntu/releases/11.10/release/MD5SUMS (depending on what file you downloaded).

If the .iso image or Wubi.exe installer (whichever you downloaded) doesn't check out, then redownload it, MD5 test the newly downloaded file, and install with the new (good) file.

If the file does have the right MD5SUM, then you should consider how you are installing it. Are you installing it with the necessary privileges? If you are running Windows Vista or Windows 7 (or a version of Windows Server corresponding to either of them), then there is something called User Account Control that (if not disabled) automatically runs programs without administrative rights, even when they are run by administrative users, unless the programs demand and are granted administrative access, or you specify when running them that they must have this access. If you're running one of these versions of Windows, then you installed Wubi, did you install it by right-clicking on Wubi.exe and clicking "Run as administrator"? If not, try that, and see if that works.

If your downloaded file has the right MD5 sum and you're either running Windows XP or you get the exact same error when you run Wubi.exe as an administrator explicitly, then you are almost certainly suffering from bug 613288. It would then be helpful for you to post there with information about your hardware and Windows version and the release (i.e., version) and flavor of Ubuntu (Xubuntu, in this case) that you are trying to install. And there are some workarounds for the bug posted on the bug page, so that might enable you to solve the problem.

It also occurs to me that you might try installing a different version of Ubuntu, which might not have the problem, or that you might try installing a more standard Ubuntu system via Wubi (the bug happened with Kubuntu, suggesting that the problem might be specific to derivatives and not happen with regular Ubuntu in Wubi), and that you might try installing a regular, non-Wubi Ubuntu system (but then, I know you've tried that here; hopefully you'll be able to get that working).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.