-1

Whenever i am trying to run an applet in my Eclipse,it's showing this error.This error was not showing when I tried to run the same program some days before.

Smooth is not supported by this hardware (or driver)
Unfolding Map v0.9.7 (UCSD edition)
Using OpenGLMapDisplay with processing.opengl.PGraphics2D
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f4168bcc040, pid=3497,tid=139919047476992
#
# JRE version: Java(TM) SE Runtime Environment (8.0_72-b15) (build 1.8.0_72-b15)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.72-b15 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [i965_dri.so+0x3ca040]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/coder/workspace/UCSDUnfoldingMaps/build/hs_err_pid3497.log
Compiled method (nm)   22323 2003     n 0       jogamp.opengl.x11.glx.GLX::dispatch_glXSwapBuffers0 (native)
total in heap  [0x00007f417c977f50,0x00007f417c9782a0] = 848
relocation     [0x00007f417c978078,0x00007f417c9780c0] = 72
main code      [0x00007f417c9780c0,0x00007f417c978298] = 472
oops           [0x00007f417c978298,0x00007f417c9782a0] = 8
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

I tried the solutions given in Eclipse (ADT) crash Failed to write core dump. Core dumps have been disabled discussions but it is of no use.

Another problem I am facing is that I even can't uninstall eclipse.Whenever I am trying to do so using the commands

sudo apt-get autoremove eclipse

or by using the command

sudo apt-get purge eclipse

It says that the package eclipse is not installed so not removed.But I did install Eclipse. So it will be better if anyone could give me the exact way to uninstall eclipse completely for fresh installation.I downloaded the tar.gz file initially and then extracted it for the initial setup of eclipse.

  • 2
    apt-get will only remove things installed with apt-get. You installed the program with a .tar.gz package, basically by source; in the same file you should find the instructions to uninstall. – Rmano Feb 17 '16 at 14:29
  • Sorry but I couldn't find such thing.Is there any way to uninstall it by command line? – Rahul Singh Feb 17 '16 at 14:33
  • After downloading the .tar.gz file, how did you exactly install it? Only locally? – Jacob Vlijm Feb 17 '16 at 14:52
  • @Jacob After downloading the tar file i extracted it and then by giving the gksu nautilus command I copy pasted the eclipse file in opt and then made a desktop entry for getting it on dash.That's it – Rahul Singh Feb 17 '16 at 15:02
  • Could paste (somewhere) the output of ls -l /opt? – Jacob Vlijm Feb 17 '16 at 15:06
0

I think rather than uninstalling Eclipse you should fix it. It's one of the necessary IDE which is needed by any Java Programmers. You can try a newer version of Eclipse like MARs if needed that comes with the installer also. Coming back to original question it seems you have unzipped/untar the Eclipse. So your best bet is to search where it is installed and then simply do

rm -rf <one level above the Eclipse installation dir>

to remove it completely.

  • I have installed it in opt .so should i first go to opt/eclipse? – Rahul Singh Feb 17 '16 at 14:40
  • rm -rf /opt/eclipse should be the right way of removing it – Ashu Feb 17 '16 at 14:41
  • If this solves your problem(removing eclipse)-do accept it as a solution and tick mark it. – Ashu Feb 17 '16 at 14:42
  • Ok.but it doesn't work out.It says cannot remove and then permission denied – Rahul Singh Feb 17 '16 at 14:43
  • sudo rm -rf /opt/eclipse – Ashu Feb 17 '16 at 14:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.