Im having problems applying a new icon theme in ubuntu 11.10 specifically with the power icon. Ive installed faenza succesfully, and the gnome tweak tool to change the icons, but the power icon doesnt seem to be updating:

Incorrect power icon

No matter what i change the icon theme to now, i cant seem to get the power icon to return to the default one, let alone the faenza one. Any suggestions where im going wrong?

  • Does this problem remain after restart or logging out? In my experience, the power manager indicator has to be restarted to apply the new icon theme. – jnv Oct 29 '11 at 16:49
  • Yea ive tried restarting a couple of times, doesnt seem to make any difference – richzilla Oct 29 '11 at 16:51

I had this problem too. I prefer the Faenza-Dark variant but has a rubbish battery icon like in your screenshot. If you used the ppa to install the icons then you should have a Faenza-Ambiance/Radiance theme to choose which fixes it, but as I prefer the -Dark variant I had to make a custom version. What I did was copied Faenza-Dark to another folder like Faenza-Custom sudo cp -r /usr/share/icons/Faenza-Dark /usr/share/icons/Faenza-Custom
Then edit it. sudo nano /usr/share/icons/Faenza-Custom/index.theme delete everything in it and paste in this

[Icon Theme]  
Comment=Icon theme project with tilish style, by Tiheum




then use gnome-tweak-tool to choose the Faenza-Custom theme and it will have the fixed battery icon

  • duffydack, thanks a lot for the tip, that worked for me, however the notification bubble that comes up once in a while when the battery is discharging, the same old (ugly) icon is still there... anything I can do about that? thanks – Valeriu Oct 29 '11 at 22:45
  • Thanks for this (I prefer the Dark variant too). There's one problem, I think: shouldn't it be "Inherits=Faenza-Dark"? – Fern Moss Oct 29 '11 at 23:09
  • Faenza is where most of the variants inherit from. All I know is, it works. – duffydack Oct 30 '11 at 11:22
  • I just unplugged mine and never got any bubble. hmm. did you make the custom icon folder 755? sudo chmod -R 755 /usr/share/icons/Faenza-Custom – duffydack Oct 30 '11 at 11:25
  • edit just did it again and had the notification, all looks fine. i.imgur.com/dxymI.png – duffydack Oct 30 '11 at 11:33

I had this problem too using Radiance theme, but I fixed it replazing the folder icons from /usr/share/Faenza-Radiance/status/22 with /usr/share/icons/ubuntu-mono-light/status/22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.