1

I had windows 8 and then i tried to install Ubuntu14.04. Installation completed successfully, but boot up failed & i got the initramfs prompt. I decided to install ubuntu again, but now my installation fails giving me a fatal error. Executing 'grub-install /dev/sda' failed. I have tried installing boot recovery etc, but nothing seems to work. Update: I tried boot-repair, and it didn't repair my grub, however it generated a report. Here is the link: http://paste.ubuntu.com/15099645/ Update: I tried using the command fsck -y /dev/sda and it gives this output: fsck from util-linux 2.20.1 e2fsck 1.42.9 (4-Feb-2014) ext2fs_open2: Bad magic number in super-block fsck.ext2: Superblock invalid, trying backup blocks... fsck.ext2: Bad magic number in super-block while trying to open /dev/sda The superblock could not be read or does not describe a valid ext2/ext3/ext4 filesystem. If the device is valid and it really contains an ext2/ext3/ext4 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device> or e2fsck -b 32768 <device>

  • run boot repair - help.ubuntu.com/community/Boot-Repair – Panther Feb 16 '16 at 16:55
  • Thank you for your reply. I installed Boot-repair as you mentioned, but when i try to repair system, it keeps giving me the message that "Filesystem repair requires to unmount partitions. Please close all your programs. Then close this window." – Syed Arslan Ali Kazmi Feb 17 '16 at 4:34
  • You need to boot a live usb and run fsck on your hard drive. fsck -y /dev/sda may be /dev/sdb when running from a live usb – Panther Feb 17 '16 at 11:55
  • @bodhi.zazen somehow i managed to unmount my partitions using gparted and Disks. Boot-repair didn't repair my grub, however it generated a report. paste.ubuntu.com/15099645 – Syed Arslan Ali Kazmi Feb 17 '16 at 13:48
  • One more thing that i noted in Disks(Genome) was that my ntfs partitions ( i have 2) keep mounting again and again and hence Boot-repair kept showing me that I need to unmount partitions. Once i unmounted them using Gparted, they never mounted again. Does it mean something? – Syed Arslan Ali Kazmi Feb 17 '16 at 13:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.