1

I can hibernate correctly my laptop, by the command sudo pm-hibernate. Even the resume works well! But if I try to hibernate by the power menu (Unity on Ubuntu 14.04 with hibernate option enabled), nothing happens. It seems that the hibernate option on power menu doesn't execute the command "sudo pm-hibernate" and when I click on this option, the screen become black for two seconds and after it returns the same as before...

How can I do? Thanks

  • I don't believe you can edit those options - those are built-ins I believe. – Thomas Ward Feb 16 '16 at 15:26
1
  • sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
  • Type in it-
  [Re-enable hibernate by default in upower]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes
  [Re-enable hibernate by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes
  • Type sudo killall unity-panel-service
  • Now you have hibernate option enabled.

    note: Don't type anything in place of *

  • hope this works :) – arvind Feb 19 '16 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.