0

I just got a new dell laptop with win10 installed. I want to dual boot with ubuntu (have done that on a couple of desktop machines) but I'm running into a problem.

I'm using this guide

I am able to boot into the usb with the installation iso no problem, I select "try ubuntu" and that is all ok.

I hit install ubuntu, and when I get to the 'installation type' section, the options are all blank.

In gparted, the only visible drive is the 8gb usb drive that contains the installation iso, the system drive is not visible.

The tutorial says I should be given the option of installing alongside windows and sizing the partition, but there is nothing available in that "installation type" dialog.

Update

still having issues. I disabled fast startup and hibernate, here is my bios boot selection: (was not connected to network and unable to save screenshot)

bios selections

here is the screen during my attempt to install ubuntu from the live usb iso

no drive available for install

and here is what shows in gparted (again from the live usb iso): gparted

I found this doc and have been going thru it. I was not able to determine how to disable the intel smart response technology.

Also, as per the tutorial in the link above, I shrunk the volume in disk management in win 10. So I now have a smaller windows partition and half the drive unallocated. Not sure if that is a problem or not.

I also tried creating a usb installer from the 14.04.3 release, same result. Used the utility linked to in the answer below. Same result.

Do the options shown here look ok as per the answers/comments below?

other resources

  • This Q on askubuntu discusses reinstalling windows in sata/ahci mode (my machine is a dell xps 9350)

  • Another tutorial on dual boot, specific to xps. Says to update bios (which I did) and to be connected to internet during install. Does not mention ahci

  • another askubuntu q with some links to resources

further updates

I changed the sata config mode to ahci, that allowed me to install ubuntu and boot into it, but I was not able to boot back into windows.

I then downloaded a win10 iso, and did a clean install with the bios set to ahci. (had to download wifi driver)

I then tried to install ubuntu. In gparted, I still only saw the usb drive, but during the ubuntu install I had the option to "install alongside windows boot manager".

The install process went forward ok, but when I went to restart, I just went straight to windows, there was no grub menu.

thanks!

  • Does this system have the new NVMe drives? Then you need the newest version of gparted from gparted. Similar system and issues: Dell Xps 15 9550 Ubuntu 15.10 on new Infinity display (i7 6gen 16gbr UHD 4k touch) ubuntuforums.org/showthread.php?t=2301071 gparted should be at least version 0.24.0-1 to recognize NVMe devices gparted.sourceforge.net/index.php – oldfred Feb 16 '16 at 19:39
  • New hardware, like many NVMe devices, often won't show up in Linux until drivers have had a chance to trickle down to distributions. You might try using the Xenial alpha to get a newer driver. – Rod Smith Feb 16 '16 at 23:31
  • I was able to install ubuntu by setting the mode to AHCI instead of RAID ON, but as per the question Ilinked to, I was then not able to boot back into windows. I think the solution is to reinstall windows and set to AHCI – badperson Feb 20 '16 at 16:12
  • You should be able to just install the AHCI drivers into Windows. Some upgraded Windows 10 systems may even be missing AHCI driver. tenforums.com/drivers-hardware/… – oldfred Feb 20 '16 at 20:00
1

Y'know, Windoze is SO slow at booting that, instead of actually killing the system and shutting down the computer, it enters an hibernation mode. This is the so-called "fast boot". When Windows is hibernating, basically nothing can be done to its partition, and that's probably the reason why the installation options are greyed out. You should disable Windows' fast boot first.

Use the following link to do it (from inside Windows):

http://www.windows10update.com/2015/05/windows-10-tutorials-66-how-to-enable-or-disable-fast-startup/

1
  1. Disable secure boot in BIOS.
  2. Also make sure that you are installing Ubuntu in EFI mode as Windows is also installed in EFI mode.
  3. Turn off hibernation and fast boot from Windows
  4. Check your ISO image. If possible use Universal USB Installer as in this link

When downloading Ubuntu - I will suggest go for LTS release - current one is 14.04.3 specifically Desktop - 64 bit(if your machine is 64 bit). Very soon(in April, we are going to get 16.04 LTS)

  • the iso I downloaded is ubuntu-15.10-desktop-amd64.iso, and I have an intel chip. is this the correct iso to use? – badperson Feb 16 '16 at 1:20
  • @badperson. Please check the size or MD5 signature to verify that. – Ashu Feb 16 '16 at 2:36
  • Your tips are reasonable general-purpose tips; however, the problem is that the NVMe drive is not showing up as an option. This is most likely because of a missing driver. If so, your suggestions won't help at all. – Rod Smith Feb 16 '16 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.