0

I've created a new virtual lab on KVM to test the last release of Juju Gui.

In this environment I've created:

  • a VM for MaaS and with 2 network interface (one for public (NAT) and one for private (isolated);
  • a VM to deploy Juju Gui.

on Maas Server the network interface are so configurated

    auto eth0 
    iface eth0 inet static
    address 1.1.100.10
    netmask 255.255.255.0
    network 1.1.100.0
    broadcast 1.1.100.255
    gateway 1.1.100.1
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 1.1.100.1
    #dns-search maas

    auto eth1 
    iface eth1 inet static
    address 1.1.101.10
    netmask 255.255.255.0
    network 1.1.101.0
    broadcast 1.1.101.255
    gateway 1.1.101.1
    # dns-* options are implemented by the resolvconf package, if installed
    #dns-nameservers 1.1.101.1
    #dns-search maas

while on virt-manager both Virtual Net are so set

enter image description here

enter image description here

on Maas UI

enter image description here

the network

enter image description here

But while I try to make the bootstrap of the environment using the following command:

$: sudo juju bootstrap -e maas --to JujuGui.maas --debug

at the end of the procedure receive that error

enter image description here

if I tried to run this

$: wget https://streams.canonical.com/juju/tools/releases/juju-1.25.3-trusty-amd64.tgz

the download started without problem

enter image description here

While on Maas the node result deployed

enter image description here

I've also try nslookup, dig and ping commands for that url and all commands gave me right result.

why?

1

I am also using the forwarding NAT Network but it can not fix the issue. The vm doesn't have internet access. That is why it is stuck at the downloading steps and make whole bootstrap failed.

Here I follow other's solution and test in my lab env. It works fine:

  1. mkdir ~./.juju/sync-tools
  2. set sync-tool destination folder.

    • If maas 1.8 version:

      sudo juju sync-tools -e maas --destination="/home/xxx/.juju/sync-tools/"
      
    • If maas 1.9 version:

      sudo juju sync-tools -e maas --local-dir="/home/xxx/.juju/sync-tools/"
      

Here is the bootstrap command:

~/.juju$ juju bootstrap --upload-tools=true --metadata-source="/home/xxx/.juju/sync-tools"  --to bootstrap-node.maas --debug
0

Maybe you need to specify a proxy for https? You got a connection refused error, but the service is up on Canonical's end.

  • the network is configured as showed above, if I try to do a ping to google.co.uk the result is right for me the navigation to external is working – Riccardo Magrini Feb 18 '16 at 15:22
  • using this command $: juju bootstrap -e maas --to JujuGui.maas --upload-tools --debug the result has been right look the log paste.ubuntu.com/14696174 – Riccardo Magrini Feb 18 '16 at 15:37
  • and if try to deploy juju-gui obtain this error: "juju deploy juju-gui --to 0 ERROR cannot retrieve charm "cs:trusty/juju-gui-48": cannot get archive: Get api.jujucharms.com/charmstore/v4/trusty/juju-gui-48/archive: dial tcp 162.213.33.122:443: connection refused" – Riccardo Magrini Feb 18 '16 at 15:42
  • --upload-tools bypasses the download of the tools tarball, that's why you don't get the error. I think you have a network egress restriction at your site that prevents you from accessing port 443/TCP directly. The fact that navigation works (have you tried https?) could just indicate that your browser is already configured to use a proxy. – Andreas Hasenack Feb 18 '16 at 19:36
  • I've upgraded the post – Riccardo Magrini Feb 19 '16 at 12:28
0

The .cloud-install/commands.log file shows this error:

Attempt 5 to download tools from https://streams.canonical.com/juju/tools/agent/1.25.3/juju-1.25.3-trusty-amd64.tgz...
curl: (7) Failed to connect to streams.canonical.com port 443: Connection timed out

It attempts to download the tar file five times and then fails.

Can someone help me?? Thanx in advance.

0

I've resolved that changed the vNet Private on Virtual Networks of virt-manager from Isolated to Forwarding

enter image description here

Certainly that one is not a right solution, but at moment it's only solution I've found.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.