I installed bumblebee to save some battery on my laptop. It works very well. When I boot the computer cat /proc/acpi/bbswitch says OFF. When i run an application with primusrun, cat /proc/acpi/bbswitch says ON as expected, but it doesn't go back to OFF when the application quits. I have seen questions about similar problems but no answers. The only thing I have found is that you can run sudo rmmod nvidia && sudo tee /proc/acpi/bbswitch <<<OFF to disable the NVIDIA graphics card manually.

  • I'm confused, why are you trying to disable your graphics card? You kinda need that to stay on if you want to see anything on the screen. Feb 15, 2016 at 20:54
  • 1
    I have two graphics cards, on from NVIDIA (which has better performance but draws more battery) and one from intel (which draws less battery but is not as good). I want to use the one from intel except when I am using a more demanding application such as a game. Once I am done playing I want to switch back to Intel's card to save battery.
    – GKraft
    Feb 16, 2016 at 13:03

2 Answers 2


Had the same behaviour a while ago on Xubuntu 15.10 (64bit) with bumblebee and nvidia-355 (installed from here). There might to be some issues in Bumblebee with removing nvidia kernel module when it has a alias in modprobe.d, something to do with modprobe vs. insmod/rmmod I think.

Warning: I tried other things before this one so this might or might not be the complete fix.

Starting point was that I had an otherwise working configuration except NVIDIA GPU stayed on after running something with optirun. I then edited /etc/modprobe.d/nvidia-graphics-drivers.conf and commented out line (which probably get overwritten on driver updates and will have to be fixed again):

#alias nvidia nvidia_355

In /etc/bumblebee/bumblebee.conf I use Driver=nvidia with these settings:


After this Bumblebee removes nvidia_355 kernel module ok and optirun --status reports "Discrete video card is off".

EDIT: removed commenting out "alias nvidia-uvm", tested and no need to comment out, might even be bad idea.

EDIT2: these settings should work also with nvidia-361 drivers if you update the settings above from "355" to "361". In addition with current bumblebee package from universe (3.2.1-9), you have to add blacklisting for 361 to /etc/modprobe.d/bumblebee.conf and add nvidia-modeset to the "remove line" at the end of the file i.e. change:

# Workaround to make sure nvidia-uvm is removed as well
remove nvidia rmmod nvidia-uvm nvidia


# 361
blacklist nvidia-361
blacklist nvidia-361-updates
blacklist nvidia-experimental-361
# Workaround to make sure nvidia-uvm is removed as well
remove nvidia rmmod nvidia-modeset nvidia-uvm nvidia

EDIT3: with nvidia-364 change remove line to:

remove nvidia rmmod nvidia-drm nvidia-modeset nvidia-uvm nvidia
  • Sounds interesting. I'll test this later.
    – GKraft
    Feb 20, 2016 at 17:25
  • It didn't work. When i boot the computer it says "Discrete video card is off", and while running an application with primusrun it says "1 applications using bumblebeed". But when the application ends ti says "Discrete video card is on". I am using nvidia-361 as my graphics driver by the way.
    – GKraft
    Feb 21, 2016 at 11:00
  • I too updated to nvidia-361 yesterday. I noticed that /etc/modprobe.d/bumblebee.conf has blacklisting only up to nvidia-355 so that is one thing you could try add for 361 and then there is a line at the end "remove nvidia rmmod nvidia-uvm nvidia" which should probably be "remove nvidia rmmod nvidia-modeset nvidia-uvm nvidia" (add nvidia-modeset). This at least with Xubuntu 15.10 and bumblebee from universe repository.
    – kk78
    Feb 21, 2016 at 11:23
  • I did add the lines for blacklisting nvidia-361 but I didn't edit the last line. I'll try that aswell.
    – GKraft
    Feb 21, 2016 at 12:20
  • It works! /etc/modprobe.d/nvidia-graphics-drivers.conf is missing so I couldn't edit that part, but it works anyway. Thank you.
    – GKraft
    Feb 21, 2016 at 12:27

Remove bumblebee and use nvidia-prime to disable NVIDIA and switch to intel graphics. Bumblebee was replaced by nvidia-prime to switch between intel and NVIDIA graphics.

sudo apt-get purge bumblebee
sudo apt-get update  
sudo apt-get install nvidia-prime  

Open NVIDIA X Server Settings -> PRIME Profiles -> select Intel -> log out and back in.

enter image description here

  • This method is the one I was using before and will probably be the one I switch back to. It is just very annoyning having to log out each time you change the settings.
    – GKraft
    Feb 16, 2016 at 13:04
  • @GKraft : Yes, you should do it - I suggest that when you use the PC for demanding tasks (like playing games), use the NVIDIA graphics and when you are using the PC for normal tasks, use intel graphics. :)
    – cl-netbox
    Feb 16, 2016 at 13:15
  • Thank you. I'll go with this method. It works much better.
    – GKraft
    Feb 16, 2016 at 13:34
  • I thought the aswer by @kk78 answered my original question better, even though your answer might actually be a better hting to do.
    – GKraft
    Feb 21, 2016 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.