0

I'm a new Ubuntu user and I did this steps recently, with 'AskUbuntu' support: - installation of Ubuntu, ownCloud server + client, Oracle VirtualMachine - configured ddns (duckdns.org) - port forward, necessary for the ddns work properly.

I can access Owncloud from other machines, using my local network. But I can't access my owncloud server when I'm outside of my local network. I'm using wired network at home, where the Ubuntu machine is installed.

Talking to a friend I realized that I need to set up a static IP to make the DDNS work properly and, then, have access to ownCloud from outside my local network. I searched the documentation at https://help.ubuntu.com/lts/serverguide/network-configuration.html

Then, I followed all the advices and changed the files /etc/network/interfaces /etc/resolv.conf /etc/hosts

I used my address, netmask and gateway. I'm sure the numbers used to address, netmask and gateway are correct. I used 'ifconfig' and route -n to check it.

I also restarted the network, shutting down the system. After start the machine again, the wired network doesn't work.

Please help me to find where is my mistake.

Thanks a lot!

  • It's hard to guess unless you include the contents of those files - or at least a clearer definition of "doesn't work" (interface doesn't come up? doesn't accept incoming traffic? doesn't route outgoing traffic? doesn't resolve names?) – steeldriver Feb 15 '16 at 17:54
  • Editing the files you described only changes things for the machine on which you've made the changes. – earthmeLon Feb 15 '16 at 18:02
0

In order for machines outside of your LAN (ie: The Internet, WAN) to have access to a machine inside of your LAN, you'll need a few things.

  1. The WAN IP for your Network
  2. A NAT-capable Router/Gateway
  3. Port-Forwarding from the WAN IP:PORT to the LAN IP:PORT

WAN IP

You can set up a true DNS solution if your IP doesn't change. Another option would be to look into dynamic dns providers.

Depending on your Router/Gateway, you may have settings to automatically update different dynamic dns providers with your new IP if it changes. I would recommend using one of these services if your Router/Gateway supports it. One such Router/Gateway firmware that supports dynamic dns is DD-WRT.

NAT

This just means you need to have a Router/Gateway that allows multiple clients to connect to it and share the Internet connection. This is a typical setup, but thought it was worth mentioning.

Port Forwarding

You will be connecting to ownCloud through ports 80 or 443 (TCP). This is http:// or https://, so it is highly recommended that you connect and force connections through https.

Your Router/Gateway needs to be set up so that it forwards all connections from its WAN IP:PORT to your machine's LAN IP:PORT.

On the machine running ownCloud, you can run ifconfig to determine your IP. Go to your Router/Gateway configuration and ensure these ports are forwarded.

  • Thanks! My WAN IP is dynamic and I'm using DuckDNS as provider for dynamic dns. My router allows multiple clients and the port forwarding is OK using a http:// for a while. I will configure the https:// as soon as solve the problem I mentioned here. – Hugo Feb 15 '16 at 18:33
  • Nice. Do you understand that you're missing Port Forwarding? Also, I highly recommend you go ahead and get HTTPS working on your LAN and solve that problem BEFORE opening ownCloud up to the Internet. – earthmeLon Feb 15 '16 at 18:36
  • I did the port forwarding since the begining. It's ok, I configure the https before set up the static ip. Thanks! – Hugo Feb 15 '16 at 18:54
  • If this answer helped you, please mark it as a solution :D Best of luck! – earthmeLon Feb 15 '16 at 18:57
  • Well, let me be more precise, as @steeldriver asked. My IP Address is 189.6.17.141 (www.whatismyip.com). The ifconfig command returns as follows: – Hugo Feb 16 '16 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.