3

I own a MSI GP62 6QE-260XFR, which is a laptop featuring an i5-6300HQ CPU and a GTX 950M graphics card, sold without OS.

I've installed Windows 10 on a partition. It works just fine. My problem is that I'm unable to run a Linux OS without the acpi=off boot option.

The boot error is the following:

ACPI : EC: Fail in evaluating the _REG object of EC device. Broken bios is suspected.

I've managed to install and run Ubuntu on a partition thanks to this guide (in French) for recent MSI computers. It basically consisted in:

  • Disabling CPU C-States in BIOS
  • Running an Ubuntu Live USB with the following boot options: nouveau.blacklist=1 acpi=off before quiet splash
  • Installing Ubuntu
  • Running the installed OS with the same boot options
  • Updating the system and installing NVIDIA drivers

By then I should have been able to run Ubuntu without acpi=off, but I get the same error message as before. I've installed the latest version of the kernel (4.4.1), hoping it would be more compatible with my PC but the problem is the same.

Thanks to the ACPI being disabled, I can't see battery levels, which makes Ubuntu a bit unusable. Does someone know what I should do?

2
  • What special options, please elaborate?
    – Ashu
    Commented Feb 15, 2016 at 12:22
  • For more details, here is my /var/log/kern.log: paste.ubuntu.com/15078065
    – Kyrio
    Commented Feb 15, 2016 at 17:19

1 Answer 1

0

I have the same Nvidia GTX 950 M graphics card and I made it work following:

sudo apt-get purge nvidia*  
sudo reboot

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-361 
sudo reboot  

I didn't specified any such params and I had just blacklisted nouveau and nothing else. My laptop is working all fine. I upgraded to kernel 4.2.5 for wifi issues.

Please refer to this thread for more info.

18
  • 1
    I don't think the boot error really comes from the graphics card, but my drivers come from the same ppa as yours, though their version is 361. Did you add the nouveau blacklist in your permanent grub settings? I've tried to remove acpi=off but since the error comes from ACPI, I get the same error message.
    – Kyrio
    Commented Feb 15, 2016 at 12:48
  • @Kyrio : You are right ... the newest drivers version available is 361 ... I think your problem has more something to do with your intel skylake CPU, which is known for having some compatibility issues. :)
    – cl-netbox
    Commented Feb 15, 2016 at 13:24
  • @netbox Yes, I've read about that. But the kernel error doesn't seem CPU-related, and the guy who wrote the guide I used has a working Ubuntu with the exact same CPU :/ Plus Linux kernel 4.4 is designed for Skylake compatibility.
    – Kyrio
    Commented Feb 15, 2016 at 13:33
  • @Kyrio : Yes ... but you installed kernel 4.4.1 manually and not from the repositories, that's a difference ! :)
    – cl-netbox
    Commented Feb 15, 2016 at 13:36
  • 1
    Just asking, maybe BIOS should be updated?
    – Avamander
    Commented Feb 15, 2016 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .