1

I want to upgrade gnuradio companion but I do not know any command any one who know please help me?

  • Why do you want a newer version of the software? Do you need to use a feature that was added or does it fix a bug for you? Otherwise just leave it the way it is. You can always upgrade to a newer Ubuntu release. Wily has gnuradio 3.7.8 currently. – David Foerster Feb 15 '16 at 10:11
  • because of some modules or files supported in a newer version – ashe Feb 15 '16 at 11:32
1

You can build it from sources, of cource, or install via PyBombs. I like the way with PyBombs. You got a most newer version, but i recommend to REMOVE currently installed via apt-get version of gnu-radio:

sudo apt-get remove gnuradio* libgnuradio-*

Do not forget to remove the libraries that depends on gnuradio. If something goes wrong, you can always install them back :)

First, install pip

sudo apt-get install python-pip python-dev build-essential
sudo pip install --upgrade pip
sudo pip install --upgrade virtualenv

Next: PyBombs

sudo pip install PyBOMBS
sudo pybombs prefix init /usr/local -a default_prx
sudo pybombs config default_prefix default_prx
sudo pybombs recipes add gr-recipes git+https://github.com/gnuradio/gr-recipes.git
sudo pybombs recipes add gr-etcetera git+https://github.com/gnuradio/gr-etcetera.git

Next, install gnuradio:

sudo pybombs install gnuradio

If you are like to use beautiful gr-fosphor, install it by:

sudo apt-get install libfreetype6-dev ocl-icd-opencl-dev libqt4-opengl-dev
sudo pybombs install gr-fosphor

Thats it, we are done!

PS: to avoid some possible errors, check if you gcc-compiler version are >= 5, but not => 6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.