0

so I've just started using Ubuntu a few days ago, started trying to get an IDE working for Ruby on Rails developement, downloaded/installed everything from scratch. I found out the first version of Ruby I had on here was 1.9.1 so I updated to 2.3.0 and now its throwing this error whenever I try to make a new rails.

/usr/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find railties (>= 0) amongst [bundler-unload-1.0.2, did
_you_mean-1.0.0, executable-hooks-1.3.2, gem-wrappers-1.2.7, minitest-5.8.4, minitest-5.8.3, net-telnet-0.1.1, power_assert-0.2
.7, power_assert-0.2.6, rake-10.5.0, rake-10.4.2, rdoc-4.2.2, rubygems-bundler-1.4.4, rvm-1.11.3.9, test-unit-3.1.7, test-unit-
3.1.5] (Gem::LoadError)
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
        from /usr/lib/ruby/1.9.1/rubygems.rb:1231:in `gem'
        from /usr/local/bin/rails:22:in `'
1

Try run:

gem install bundler
bundle update 

or maybe re-install rails:

gem install rails

If not working you can re-install the rails for your version of ubuntu in this link https://gorails.com/setup/ubuntu/16.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.